Making WordPress.org

Opened 14 months ago

Closed 4 weeks ago

#2483 closed defect (duplicate)

Trac: Different Gravatars for the same user.

Reported by: SergeyBiryukov Owned by: obenland
Milestone: Priority: normal
Component: Trac Keywords:


Why does Trac show different Gravatars for the same user in the same ticket?

See the screenshot.

Attachments (3)

meta-2483.png (57.1 KB) - added by SergeyBiryukov 14 months ago.
2483.otto42-wporg.PNG (76.6 KB) - added by SergeyBiryukov 12 months ago.
2483.otto42-trac.PNG (15.2 KB) - added by SergeyBiryukov 12 months ago.

Download all attachments as: .zip

Change History (10)

#1 @netweb
14 months ago

The users profile only shows the "Mystery Man" /shrug


#2 @SergeyBiryukov
12 months ago

Could be related: @Otto42's WP.org profile shows a proper Gravatar, while Trac shows a fallback image.

#3 @Otto42
12 months ago

Trac doesn't handle gravatars correctly because of the way we're doing it. It's complicated and weird.

However, my gravatar is fine. :)

#4 @obenland
4 weeks ago

  • Owner set to obenland
  • Resolution set to fixed
  • Status changed from new to closed

In 6682:

Trac: Don't strip periods from user names,

Fixes #2483.

#5 @ocean90
4 weeks ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

This is actually a duplicate of #1462 and [6682] should probably be reverted because dots are not allowed in user_nicename.

#6 @obenland
4 weeks ago

In 6688:

Trac: Holy can of worms batman!

Reverts [6682] in favor of a more permanent solution in #1462.

Props ocean90.
See #2483.

#7 @obenland
4 weeks ago

  • Resolution set to duplicate
  • Status changed from reopened to closed

Duplicate of #1462.

Note: See TracTickets for help on using tickets.