WordPress.org

Making WordPress.org

Opened 2 years ago

Closed 2 years ago

#2525 closed defect (worksforme)

O2: Small letter x doesn't mark an item as 'done'

Reported by: SergeyBiryukov Owned by:
Milestone: Priority: normal
Component: Make (Get Involved) / P2 Keywords: has-screenshots
Cc:

Description

On P2/O2, small letter o or a small letter x are used to create to-do list items:
https://p2guide.wordpress.com/2012/04/26/writing-to-do-lists-check-boxes/

However, small letter x doesn't always work for some reason, as seen in this post.

Attachments (2)

meta-2525.PNG (51.2 KB) - added by SergeyBiryukov 2 years ago.
meta-2525.2.PNG (39.0 KB) - added by SergeyBiryukov 2 years ago.

Download all attachments as: .zip

Change History (5)

#1 follow-up: @ocean90
2 years ago

  • Keywords close added

There is/was a non-breaking space after the x:

<p>x&nbsp;<a href="https://meta.trac.wordpress.org/ticket/1868">Profiles list of replies is not as useful as the old one</a></p>

#2 in reply to: ↑ 1 @SergeyBiryukov
2 years ago

  • Keywords close removed

Replying to ocean90:

There is/was a non-breaking space after the x

Thanks! I removed the non-breaking spaces, but there's something else that breaks the markup completely, apparently due to r4122-meta and r4123-meta links implemented in #1167, see meta-2525.2.PNG.

&lt;li class='o2-task-item o2-task-sortable o2-task-completed' data-item-hash='29a437b70300b32eacb10e487a51d787' data-hash-instance='0' data-item-text='&lt;a href="https://meta.trac.wordpress.org/ticket/1967"&gt;Moderators cannot see IPs and emails on profiles or in posts&lt;/a&gt; (fixed in <a href="https://meta.trac.wordpress.org/changeset/4122">r4122-meta</a> and <a href="https://meta.trac.wordpress.org/changeset/4123">r4123-meta</a>)' &gt;<input type="checkbox" name="" value="" checked><span class="o2-task-item-text"><a href="https://meta.trac.wordpress.org/ticket/1967">Moderators cannot see IPs and emails on profiles or in posts</a> (fixed in <a href="https://meta.trac.wordpress.org/changeset/4122">r4122-meta</a> and <a href="https://meta.trac.wordpress.org/changeset/4123">r4123-meta</a>)</span>

The changes in #1167 not open-sourced though, and I could not reproduce the issue on a local install, it appears to be dotorg-specific. I can remove those links for now, but I think it might eventually occur somewhere else.

#3 @SergeyBiryukov
2 years ago

  • Resolution set to worksforme
  • Status changed from new to closed

Moved the latest issue to a separate ticket: #2526.

Note: See TracTickets for help on using tickets.