WordPress.org

Making WordPress.org

Opened 2 years ago

Closed 2 years ago

#2526 closed defect (fixed)

O2: Trac links don't play nicely with to-do list items

Reported by: SergeyBiryukov Owned by:
Milestone: Priority: normal
Component: Make (Get Involved) / P2 Keywords: has-screenshots
Cc:

Description

Background: #2525

  1. Paste this into a new post (it's supposed to be a completed to-do item, as seen live in this post):
    x <a href="https://meta.trac.wordpress.org/ticket/1967">Moderators cannot see IPs and emails on profiles or in posts</a> (fixed in r4122-meta and r4123-meta)
    
  2. The resulting markup is broken, see the screenshot:
    &lt;li class='o2-task-item o2-task-sortable o2-task-completed' data-item-hash='29a437b70300b32eacb10e487a51d787' data-hash-instance='0' data-item-text='&lt;a href="https://meta.trac.wordpress.org/ticket/1967"&gt;Moderators cannot see IPs and emails on profiles or in posts&lt;/a&gt; (fixed in <a href="https://meta.trac.wordpress.org/changeset/4122">r4122-meta</a> and <a href="https://meta.trac.wordpress.org/changeset/4123">r4123-meta</a>)' &gt;<input type="checkbox" name="" value="" checked><span class="o2-task-item-text"><a href="https://meta.trac.wordpress.org/ticket/1967">Moderators cannot see IPs and emails on profiles or in posts</a> (fixed in <a href="https://meta.trac.wordpress.org/changeset/4122">r4122-meta</a> and <a href="https://meta.trac.wordpress.org/changeset/4123">r4123-meta</a>)</span>
    

It works as expected if I remove r4122-meta and r4123-meta, so apparently it has to do with the links implemented in #1167. The changes in that ticket not open-sourced though, and I could not reproduce the issue on a local install with O2, so it appears to be dotorg-specific.

Attachments (1)

meta-2526.PNG (39.0 KB) - added by SergeyBiryukov 2 years ago.

Download all attachments as: .zip

Change History (3)

#1 @SergeyBiryukov
2 years ago

  • Keywords has-screenshots added

#2 @ocean90
2 years ago

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in [dotorg12927] (same fix as in [4249]).

Note: See TracTickets for help on using tickets.