WordPress.org

Making WordPress.org

Opened 3 years ago

Closed 3 years ago

Last modified 14 months ago

#2546 closed defect (invalid)

Contact page only available when logged on

Reported by: casiepa Owned by:
Milestone: Priority: normal
Component: WordPress.tv Keywords:
Cc:

Description

The contact page on https://wordpress.tv/contact/ gives an 'Uh oh, someone made a mistake!' 404 error page. Only for users LOGGED IN to wordpress.COM , the form is correctly displayed.

Change History (8)

#1 @coreymckrill
3 years ago

@casiepa Is the URL the same once you're logged in and see the form? I am logged into my WP.com account and the URL above still gives me a 404.

#2 @SergeyBiryukov
3 years ago

I can reproduce in the latest Chrome exactly as described: the page displays the contact form if I'm logged in on WP.com, and a 404 error otherwise. The URL is the same in both cases.

#3 follow-up: @coreymckrill
3 years ago

@SergeyBiryukov do you have a user role on WPTV? After chatting with @casiepa we determined that his role as mod may be the reason he can see the page when logged in.

I don't have a role on the site, so I can't tell for sure, but my guess is that the page is marked as "private", and setting it to "public" might fix the 404. A related question in that case would be, why is it private? There's no link to the contact page in the navigation (unless you are on blog.wordpress.tv, a separate site) so maybe we don't need that page anyway?

#4 in reply to: ↑ 3 @SergeyBiryukov
3 years ago

Replying to coreymckrill:

@SergeyBiryukov do you have a user role on WPTV? After chatting with @casiepa we determined that his role as mod may be the reason he can see the page when logged in.

Indeed, that would be the reason in my case too.

A related question in that case would be, why is it private? There's no link to the contact page in the navigation (unless you are on blog.wordpress.tv, a separate site) so maybe we don't need that page anyway?

It looks like the link to the page was removed from the site footer in #1758, so maybe it should be removed from blog.wordpress.tv as well.

This ticket was mentioned in Slack in #wptv by casiepa. View the logs.


3 years ago

#6 @jwparky
3 years ago

I am finding two pages that show a link to the Contact page and form.

Submission Guidelines page

https://blog.wordpress.tv/submission-guidelines/

Blog

https://blog.wordpress.tv

Hope that helps.

#7 @coreymckrill
3 years ago

  • Resolution set to invalid
  • Status changed from new to closed

As with #1758, this can presumably be resolved by modifying the dynamic menu on blog.wordpress.tv. I'm going to go ahead and close this.

This ticket was mentioned in Slack in #wptv by casiepa. View the logs.


14 months ago

Note: See TracTickets for help on using tickets.