WordPress.org

Making WordPress.org

Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#2566 closed defect (fixed)

Forums: No "Keep a log of this edit" option for replies

Reported by: SergeyBiryukov Owned by: SergeyBiryukov
Milestone: Priority: normal
Component: Support Forums Keywords:
Cc:

Description

When editing a topic, there's a "Keep a log of this edit" option that can be disabled.

When editing a reply, the option is not displayed. The code is there, it's just hidden by bb-base theme styles.

The issue is caused by a markup inconsistency between form-topic.php and form-reply.php:

In form-topic.php the <legend> element contains only the Revision label:

<legend><?php _e( 'Revision', 'wporg-forums' ); ?></legend>
<div>
	<input name="bbp_log_topic_edit" id="bbp_log_topic_edit" type="checkbox" value="1" <?php bbp_form_topic_log_edit(); ?> />
	<label for="bbp_log_topic_edit"><?php _e( 'Keep a log of this edit:', 'wporg-forums' ); ?></label><br />
</div>

In form-reply.php, the <legend> element contains the whole input:

<legend>
	<input name="bbp_log_reply_edit" id="bbp_log_reply_edit" type="checkbox" value="1" <?php bbp_form_reply_log_edit(); ?> />
	<label for="bbp_log_reply_edit"><?php esc_html_e( 'Keep a log of this edit:', 'wporg-forums' ); ?></label><br />
</legend>

Looks like form-topic.php should be updated to use the same markup, see [bb5060].

Change History (3)

#1 @SergeyBiryukov
2 years ago

  • Owner set to SergeyBiryukov
  • Resolution set to fixed
  • Status changed from new to closed

In 5113:

Support Theme: Improve markup and styling for topic and reply edit forms:

  • Add breadcrumbs to topic edit form.
  • Display "Keep a log of this edit" checkbox in edit reply form.
  • Some minor style adjustments for visual consistency.

Fixes #2566.

#2 @netweb
2 years ago

As an addendum to this, on bbPress.org and BuddyPress.org revisions are disabled so the checkbox for "Keep a log of this edit" is not available..

#3 @SergeyBiryukov
2 years ago

In 5120:

Support Theme: After [5113], show legends in topic and reply forms on edit pages, but keep them hidden on singular pages.

See #2566.

Note: See TracTickets for help on using tickets.