WordPress.org

Making WordPress.org

Opened 3 years ago

Closed 3 years ago

#2577 closed defect (worksforme)

Trac redirects to WP.org profile on login

Reported by: SergeyBiryukov Owned by:
Milestone: Priority: normal
Component: Login & Authentication Keywords:
Cc:

Description

When logging in via Trac (tested on Core and Meta), you're redirected to your WP.org profile, not back to the Trac.

Change History (5)

#1 @Otto42
3 years ago

Cannot reproduce this. It redirects back to the trac in question when I log in. Note the hidden redirect_to input fields having the meta.trac or core.trac URLs in them on the login form.

#2 @lukecavanagh
3 years ago

@SergeyBiryukov

I did have that issue this morning, I was viewing a core ticket, noticed I was not logged in. So logged in, but it did redirect to profile and not back to the referring URL. But I just logged out from this meta ticket, went to login from this ticket and after login it did redirect correctly.

So the issue only seems to happen some of the time.

Last edited 3 years ago by lukecavanagh (previous) (diff)

#3 @SergeyBiryukov
3 years ago

Hmm, can't reproduce now either. But I noticed this URL in the page source after I triggered captcha at some point:

<input type="hidden" name="redirect_to" value="https://login.wordpress.org/wp-admin/" />

even though I only tried logging in to Meta Trac and never visited that URL.

#4 follow-up: @Otto42
3 years ago

The default is for it to go to your profile. So, if you're somehow not sending referrer information, then it would go to your profile. Got any privacy extensions running?

#5 in reply to: ↑ 4 @SergeyBiryukov
3 years ago

  • Resolution set to worksforme
  • Status changed from new to closed

Replying to Otto42:

Got any privacy extensions running?

None. It's still not quite clear where name="redirect_to" value="https://login.wordpress.org/wp-admin/" came from, but I guess it's a worksforme until I find a way to consistently reproduce it.

Note: See TracTickets for help on using tickets.