WordPress.org

Making WordPress.org

Opened 2 years ago

Closed 18 months ago

#2602 closed defect (duplicate)

Do not apply hovercards on tickets within link tags

Reported by: swissspidy Owned by:
Milestone: Priority: normal
Component: Make (Get Involved) / P2 Keywords:
Cc:

Description

As can be seen on https://make.wordpress.org/cli/handbook/wish-list/, the ticket preview script fails when trying to load information for a ticket. The tickets exist, but of course reference GitHub issues, not Trac tickets.

Given that these ticket numbers are within existing <a> tags, I think the hovercard script should skip any already linked tickets.

Change History (4)

#1 @ocean90
2 years ago

Well, the script only works if tickets/changesets are inside of link tags so we can't skip them. Maybe we should just make them work with GitHub links.

#3 @SergeyBiryukov
2 years ago

Is https://github.com/Automattic/p2-hovercards the relevant code, or is it a custom dotorg script? Looking at #1167, seems like the latter.

#4 @obenland
18 months ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #2440.

Note: See TracTickets for help on using tickets.