WordPress.org

Making WordPress.org

Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#2617 closed defect (invalid)

Plugin Directory Search Results

Reported by: lukecavanagh Owned by:
Milestone: Priority: normal
Component: Plugin Directory Keywords: close
Cc:

Description

So searching for the following search terms, based on the tags being used by a plugin, so the example plugin was Formidable Forms.

Formidable Forms test search terms

form
https://wordpress.org/plugins/search/form/page/3/

forms
https://wordpress.org/plugins/search/forms/page/2/

contact form
https://wordpress.org/plugins/search/contact+form/page/10/

form builder
https://wordpress.org/plugins/search/form+builder/page/3/

custom form
https://wordpress.org/plugins/search/custom+form/page/2/

So for a plugin with 300,000+ active installs it does not show in the results on page one for any of those search terms, is this based due to having unresolved support posts?

Change History (10)

#1 @Ipstenu
2 years ago

  • Keywords close added
  • Milestone Plugin Directory v3.0 deleted
  • Resolution set to invalid
  • Status changed from new to closed

Searching for single-common-terms is always going to suck. Same thing happens on Google.

https://wordpress.org/plugins/tags/forms/ however has Formidable on page 1.

Same with https://wordpress.org/plugins/tags/form/

So this is an expectation issue. Searching for a single term is not what users actually do. If they use tags, they use tags.

This has been gone over multiple times. See #1692

#2 @lukecavanagh
2 years ago

@Ipstenu

But

contact form, form builder, form plugin are not single search terms.

#3 @Ipstenu
2 years ago

They're generic/common terms.

Also "foobar plugin" is equivalent to "foobar" because plugin is the second worst search term to try and prioritize for in the plugin directory ("wordpress" is the worst if you wondered).

Google search "WordPress form plugin" and look at how many pages you go before you find Formidable (middle of page 2). This is NOT a dig against them, it's just point out that it's a losing game and it's not realistic.

Use tags for tags, not for search.

#4 @lukecavanagh
2 years ago

If the issue is that not resolving support posts on the repo, or supporting a plugin on the repo, will have an effect on that plugins search ranking, then that needs to be communicated better to plugin authors.

#5 @Ipstenu
2 years ago

Luke, you're changing your horse midstream and this doesn't help anything.

Your ticket is invalid because you're attempting to use tags as search terms and that doesn't work. Google for those terms and you'll get the same result.

You can read https://data.blog/2017/03/15/improving-relevance-and-elasticsearch-query-patterns/ for more about how it all works, but it's way more complicated than because a plugin doesn't use the .org forums.

Which is not a secret by the way. Everyone knows we weight that. It's not just why the plugin you picked isn't showing up. It's that you picked a search pattern that is non-representational of how people actually use search.

Which is why THIS ticket is invalid.

#6 @lukecavanagh
2 years ago

@Ipstenu

So is there GA search term data to back up how end-users actually search for plugins on the repo, since those search terms either single or double would be pretty common ones end-users would use to search for form plugins on the WP repo.

#7 @Ipstenu
2 years ago

No, I'm just using Google as an example of why that term is a bad term, and spending time optimizing for it is futile.

Read https://data.blog/2017/03/15/improving-relevance-and-elasticsearch-query-patterns/ to understand everything that went into this search :)

We actually did study metrics on this one. Those kinds of terms? Not common for search. Users don't search for terms. They search for things like "forms plugin with editor and templates"

#8 @lukecavanagh
2 years ago

@Ipstenu

I do not get the issue with improving or optimizing search relevance?

https://www.elastic.co/guide/en/elasticsearch/guide/current/relevance-intro.html

So end-users do not search for form plugins on the WP repo, using "form plugin" or "form plugins" then?

#9 @Ipstenu
2 years ago

Please read the post I linked you to, plus the posts it links to like https://make.wordpress.org/meta/2016/08/30/initial-analysis-of-plugin-search-logs/

We did the legwork here.

I'm not going to argue with you anymore about this, since you don't seem to understand that search terms and tags are separate for a reason, and optimizing 'forms' so that a plugin you're looking for shows up earlier is fundamentally flawed when you consider that the exact same search in other engines nets similar results.

Yes, we should improve the search. This specific case that you have presented is not a valid direction of improvement as you're asking us to improve an incredibly generic term for a specific result, and that's not how search works.

#10 @SergeyBiryukov
2 years ago

  • Component changed from General to Plugin Directory
Note: See TracTickets for help on using tickets.