WordPress.org

Making WordPress.org

Opened 6 years ago

Closed 6 years ago

#263 closed defect (fixed)

Admin's visual editor broken for the mobile make blog

Reported by: aerych Owned by:
Milestone: Priority: normal
Component: Make (Get Involved) / P2 Keywords: reporter-feedback
Cc:

Description

The visual editor in the mobile make blogs admin is broken.

To reproduce: visit the mobile make blog and start a new post:
https://make.wordpress.org/mobile/wp-admin/post-new.php
Tap the visual tab for the editor if its not selected.
Notice there is no cursor and the format bar is missing.

Firebug reveals two tinymce related JS errors:
TypeError: tinymce.util.Cookie is undefined
TypeError: createBookmark(...) is undefined

Change History (4)

This ticket was mentioned in IRC in #wordpress-meta by aerych. View the logs.


6 years ago

#2 @netweb
6 years ago

Make P2 Blogs are running /trunk and this issue is due to TinyMCE 4 being added to core.

See https://core.trac.wordpress.org/ticket/24067

#3 @azaozz
6 years ago

  • Keywords reporter-feedback added

The first error (the one that matters) was probably caused by AtD and should be fixed now. Refresh browser cache before re-testing :)

#4 @Otto42
6 years ago

  • Resolution set to fixed
  • Status changed from new to closed

AtD in Jetpack causes this problem. Disabling AtD fixes it.

Jetpack needs an update for the new TinyMCE.

Note: See TracTickets for help on using tickets.