WordPress.org

Making WordPress.org

Opened 9 months ago

Closed 9 months ago

Last modified 8 months ago

#2643 closed defect (fixed)

Plugin Directory: Short Descriptions shouldn't display unrendered Markdown

Reported by: webdevmattcrom Owned by: dd32
Milestone: Plugin Directory v3.0 Priority: normal
Component: General Keywords:
Cc:

Description

Currently, if a plugin has Markdown in its short description, that is shown unrendered in the search result tiles. The "Give" plugin is a good example in these results:
https://wordpress.org/plugins/search/donations/

It seems this changeset was intended to resolve that, but perhaps that only applied to the single plugin pages and not search results:
https://meta.trac.wordpress.org/changeset/3360

Change History (2)

#1 @dd32
9 months ago

  • Owner set to dd32
  • Resolution set to fixed
  • Status changed from new to closed

In 5205:

Plugin Directory: When the Short description isn't provided, pull it from the main plugin description after markdown has been parsed - this allows the parser to strip out unwanted markup in the description.

Fixes #2643

#2 @ocean90
8 months ago

  • Milestone changed from Plugin Directory v3 - Future to Plugin Directory v3.0
Note: See TracTickets for help on using tickets.