WordPress.org

Making WordPress.org

Opened 2 years ago

Closed 2 years ago

#2647 closed defect (wontfix)

search in plugin repository by contributors name does not find their plugins

Reported by: progmastery Owned by:
Milestone: Priority: normal
Component: Plugin Directory Keywords: needs-patch
Cc:

Description

Search query in plugin directory by contributor's username or name does not return contributor's plugins.

https://wordpress.org/plugins/search/progmastery/
https://wordpress.org/plugins/search/tigran+nazaryan/

My WP profile
https://profiles.wordpress.org/progmastery/#content-plugins

Change History (3)

#1 @SergeyBiryukov
2 years ago

Related: #2624

There's an author view that's hidden at the moment: https://wordpress.org/plugins/author/progmastery/

#2 @progmastery
2 years ago

It seems this problem appeared after [5204].

I am listed as a contributor in plugin's readme.txt, but not as author in plugin main file.

Related: #2585

Last edited 2 years ago by SergeyBiryukov (previous) (diff)

#3 @Otto42
2 years ago

  • Milestone Plugin Directory v3.0 deleted
  • Resolution set to wontfix
  • Status changed from new to closed

[5204] did not introduce the problem, that simply fixed it for the API case.

Note that searching from a WordPress installation has a dropdown next to the search for Keyword, Tag, and Author searching. These appear to work correctly in my testing, and searching for an author with the Author selected will indeed return the correct results. That's what [5204] fixed.

However, the Plugin directory search displayed on the website is essentially only returning the search results as if you're doing a "Keyword" search. Since author name is not in the index as part of the plugin description or changelog or what have you, then it won't be found by such a search on the website itself.

I believe this is working as intended in this case, as the "author" fields are being specifically saved as such for those Author searches in the WordPress backend.

If you wish to present a place for people to find your plugins, then the profiles page is best for that, as you have control over what plugins are displayed there. If you want to direct people how to find your plugins in the WordPress backend admin pages, for installation, then the Author search is available, as is the Tags search, which you have a fine grain of control over as well. Alternatively, simply putting author information into your description will work for that case as well, although given the profiles listing, the Author dropdown, and even Tags, this seems unnecessary.

For these reasons, I'm closing this as wontfix for now. If at some point it makes sense to include that author information in the index as a searchable keyword, then this may be re-opened.

Note: See TracTickets for help on using tickets.