WordPress.org

Making WordPress.org

Opened 8 months ago

Closed 8 months ago

#2705 closed defect (fixed)

Readme validator: No message if all is fine

Reported by: casiepa Owned by: Otto42
Milestone: Plugin Directory v3.0 Priority: normal
Component: Plugin Directory Keywords: has-patch commit has-screenshots
Cc:

Description

The readme validator on https://wordpress.org/plugins/developers/readme-validator/ seems to work fine to indicate missing tags.

But a copy/paste in the bottom box of a 'perfect' readme file does not give any message after hitting the 'validate' button.

Please indicate something like 'All necessary tags found' or 'Readme is valid for wordpress.org upload'

Attachments (2)

2705.patch (1.2 KB) - added by SergeyBiryukov 8 months ago.
2705.PNG (13.6 KB) - added by SergeyBiryukov 8 months ago.

Download all attachments as: .zip

Change History (8)

@SergeyBiryukov
8 months ago

#1 @SergeyBiryukov
8 months ago

  • Keywords has-patch commit has-screenshots added

2705.patch adds a success notice: "Congratulations! No errors found."

#2 @SergeyBiryukov
8 months ago

  • Milestone set to Plugin Directory v3.0

This ticket was mentioned in Slack in #meta by sergey. View the logs.


8 months ago

#4 @Otto42
8 months ago

In 5331:

Plugin Directory: Readme Validator, add output of some kind on success. May need additional styling. See #2705.

This ticket was mentioned in Slack in #meta by sergey. View the logs.


8 months ago

#6 @Otto42
8 months ago

  • Owner set to Otto42
  • Resolution set to fixed
  • Status changed from new to closed

In 5333:

Plugin Directory: Add styling to the validator success message. Props @sergey. Fixes #2705

Note: See TracTickets for help on using tickets.