WordPress.org

Making WordPress.org

Opened 2 years ago

Closed 2 years ago

Last modified 21 months ago

#2765 closed enhancement (duplicate)

No indication of responses to reviews

Reported by: chriscct7 Owned by: obenland
Milestone: Priority: normal
Component: Plugin Directory Keywords:
Cc:

Description

In [5399] for #2679, in the tab for reviews there is no longer any indication from the reviews tab that there has been replies to a review. This is particularly harmful for 1 star reviews where explanations have been given but the reviewer never came back to read or alter their ratings given.

Change History (4)

#1 @Otto42
2 years ago

  • Type changed from defect to enhancement

This was not introduced by [5399], but was introduced by the general roll out of the new directory as a whole. Nevertheless, I agree that having an indication of replies made to reviews is important to have.

The code used for displaying those reviews is here:

https://meta.trac.wordpress.org/browser/sites/trunk/wordpress.org/public_html/wp-content/plugins/plugin-directory/shortcodes/class-reviews.php

Reviews are retrieved from the forums here:

https://meta.trac.wordpress.org/browser/sites/trunk/wordpress.org/public_html/wp-content/plugins/plugin-directory/class-tools.php#L47

Both of these would need modifications, to get the number of replies, and to display them.

#2 @SergeyBiryukov
2 years ago

  • Keywords needs-patch removed
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #1805.

#3 @obenland
21 months ago

  • Owner set to obenland
  • Resolution changed from duplicate to fixed

In 6351:

Breathe: Don't show navigation border on 404 page.

There is no navigation on 404 pages.

Fixes #2765.

#4 @obenland
21 months ago

  • Resolution changed from fixed to duplicate
Note: See TracTickets for help on using tickets.