WordPress.org

Making WordPress.org

Opened 8 months ago

Closed 8 months ago

Last modified 8 months ago

#2785 closed defect (invalid)

Glossary Term highlighting disappears after interacting with an entry

Reported by: garrett-eclipse Owned by:
Milestone: Priority: normal
Component: Translate Site & Plugins Keywords:
Cc:

Description

Hello,

Wanted to flag a minor issue with the Glossary term highlighting on strings. When initially viewing a string you'll note the glossary terms are underlined appropriately, however if you act on the item rejecting, etc. And then click details again to expand it the terms are no longer highlighted/underlined.

Below screen is after I rejected the translated string, as can be seen the glossary terms for catalog are no longer underlined;
http://i.imgur.com/gmUa5Ns.png

Reloading the page after submitting a translated string I can see it's re-underlined;
http://i.imgur.com/aLvTwnS.png

Since Reject seems to be done via ajax and the glossary is php, maybe on ajax updates we need a js script to re-glossary/underline terms.
*That's an assumption as I don't know nearly enough about how it works.

Let me know if you need any clarification,
Cheers

Change History (2)

#1 @ocean90
8 months ago

  • Resolution set to invalid
  • Status changed from new to closed

Thanks for the report. I could reproduce this on a clean GlotPress install so it should be reported at https://github.com/glotpress/glotpress-wp/issues.

#2 @garrett-eclipse
8 months ago

Sorry @ocean90 thought Glossary issues were a meta-wp issue, my bad.
Opened here - https://github.com/GlotPress/GlotPress-WP/issues/704

Note: See TracTickets for help on using tickets.