WordPress.org

Making WordPress.org

Opened 8 months ago

Closed 6 months ago

#2788 closed enhancement (fixed)

Plugin Directory: Clarify language for submission errors

Reported by: Ipstenu Owned by: tellyworth
Milestone: Plugin Directory v3.0 Priority: normal
Component: Plugin Directory Keywords: has-patch
Cc:

Description

The attached patch standardizes all the errors with an 'error' to describe what the problem is, and then a longer explanation of what to do to fix it.

It also fixes directions on if you try to resubmit the same plugin twice.

Attachments (7)

2788.diff (5.8 KB) - added by Ipstenu 8 months ago.
2788.2.diff (6.5 KB) - added by Ipstenu 8 months ago.
Updated patch with directions on accepted submission because people aren't reading.
2788.3.diff (7.0 KB) - added by Ipstenu 8 months ago.
This one has clearer notes about whitelisting us (not in the email) so people know who to expect the email from *SIGH*
2788.4.diff (2.9 KB) - added by SergeyBiryukov 7 months ago.
2788.5.diff (3.8 KB) - added by SergeyBiryukov 7 months ago.
2788.6.diff (3.9 KB) - added by SergeyBiryukov 7 months ago.
2788.7.diff (4.0 KB) - added by SergeyBiryukov 7 months ago.

Download all attachments as: .zip

Change History (17)

@Ipstenu
8 months ago

@Ipstenu
8 months ago

Updated patch with directions on accepted submission because people aren't reading.

@Ipstenu
8 months ago

This one has clearer notes about whitelisting us (not in the email) so people know who to expect the email from *SIGH*

This ticket was mentioned in Slack in #meta by tellyworth. View the logs.


8 months ago

#2 @ocean90
8 months ago

  • Keywords needs-refresh added

The email should be a placeholder in the strings so it doesn't get translated. Don't forget to update the translator comments.

#3 @tellyworth
8 months ago

  • Owner set to tellyworth
  • Resolution set to fixed
  • Status changed from new to closed

In 5471:

Plugin directory: clarify error messages during submission process. Props @ipstenu.

Fixes #2788

#4 @ocean90
7 months ago

  • Keywords needs-patch added; has-patch needs-refresh removed
  • Resolution fixed deleted
  • Status changed from closed to reopened

Thanks for ignoring my comment...

#5 @SergeyBiryukov
7 months ago

  • Summary changed from Plugin Direction: Clarify language for submission errors to Plugin Directory: Clarify language for submission errors

#6 @SergeyBiryukov
7 months ago

  • Keywords has-patch added; needs-patch removed
  • Milestone set to Plugin Directory v3.0

2788.4.diff switches the email address to a placeholder and updates translator comments, as per comment:2.

Moving to v3.0, as the ticket already has a commit that just needs a follow-up.

#7 @SergeyBiryukov
7 months ago

2788.5.diff is a combined patch with the changes from #2830, as they have some overlap. Whichever one gets committed first, should fix the other one as well :)

#8 @SergeyBiryukov
7 months ago

2788.6.diff is the same as 2788.5.diff, but with raw email address converted to a mailto: link for better UX.

#9 @tellyworth
6 months ago

Can someone confirm whether was fixed with r5561, or if there are further changes needed.

#10 @SergeyBiryukov
6 months ago

  • Resolution set to fixed
  • Status changed from reopened to closed

[5561] includes the fix for the issues raised in comment:2.

Note: See TracTickets for help on using tickets.