WordPress.org

Making WordPress.org

Opened 5 years ago

Closed 5 months ago

#281 closed defect (duplicate)

Plugins Trac: Plugin Component not saved

Reported by: kraftbj Owned by:
Milestone: Priority: normal
Component: Trac Keywords:
Cc:

Description

With the plugins trac being unlocked, plugin pages offer a link to open a new ticket (e.g. https://plugins.trac.wordpress.org/plugin/wp-front-end-editor with a link to https://plugins.trac.wordpress.org/newticket?component=wp-front-end-editor ).

However, the component is either not saved or not displayed on tickets created via that link, see https://plugins.trac.wordpress.org/ticket/2113 as an example.

Change History (7)

#1 @nacin
4 years ago

  • Resolution set to fixed
  • Status changed from new to closed

Fixed. The issue is that the component didn't exist yet. Working on syncing over all components very soon. I added wp-front-end-editor as a component manually.

#2 @avryl
4 years ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

Creating a new ticket on the following page still doesn't add the ticket to the right component. I have to manually change the component from not-listed to wp-front-end-editor after I created the ticket.

https://plugins.trac.wordpress.org/newticket?component=wp-front-end-editor

This ticket was mentioned in IRC in #wordpress-meta by nacin. View the logs.


4 years ago

#4 @MattyRob
3 years ago

Just found this ticket as I was going to report this same issue - it still persists and one must enter the component AFTER the ticket is created, it cannot be set at the time of creation as it isn't saved.

This could be frustrating for plugin authors and plugin users as reports may not be attached to any plugin making it harder for the plugin author to find and act on the tickets.

#5 @obenland
5 months ago

  • Keywords close added

This doesn't seem very scalable. How useful is a dropdown menu with 52,000+ options?

Can we agree that we probably should try to fix this?

#6 @MattyRob
5 months ago

@obenland

I agree that the scale of the drop down doesn’t scale well but it is already there!

It just doesn’t work so the data are not being passed or processed correctly on initial submission if a new ticket. Once the ticket exists it then works perfectly. Why this can be the case and yet so difficult to fix at same time is a mystery to me.

#7 @obenland
5 months ago

  • Keywords close removed
  • Resolution set to duplicate
  • Status changed from reopened to closed

It looks like this is a duplicate of #160 too. Let's close this one and see if Select2, which was suggested there, could be an option.

Note: See TracTickets for help on using tickets.