WordPress.org

Making WordPress.org

Opened 8 months ago

Closed 2 weeks ago

Last modified 6 days ago

#2812 closed defect (fixed)

I can't find my plugin in search results of plugin directory use the translated plugin name.

Reported by: ooqwqoo Owned by:
Milestone: Plugin Directory v3.0 Priority: high
Component: Plugin Directory Keywords: needs-patch
Cc:

Description

This is my plugin: https://wordpress.org/plugins/wx-custom-share/
I have translated the plugin and plugin readme to zh_CN, but when I use translated plugin name as keyword to search something in plugin directory, my plugin is not show in results.
Is possible to do it?

Change History (11)

#1 @ocean90
8 months ago

  • Milestone Plugin Directory v3.0 deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #1496.

#2 @gibrown
8 months ago

  • Milestone set to Plugin Directory v3.0
  • Resolution duplicate deleted
  • Status changed from closed to reopened
  • Type changed from enhancement to defect

@ocean90 I think we should leave this open. It seems to be different root cause than #1496. 1496 is working on the plugin search for that locale (ru). This plugin though is not showing up in search results at all even though it is clearly translated.

https://cn.wordpress.org/plugins/wx-custom-share/

https://cn.wordpress.org/plugins/search/%E8%87%AA%E5%AE%9A%E4%B9%89%E5%BE%AE%E4%BF%A1%E5%88%86%E4%BA%AB/

It looks like the translated strings are not being properly synced (I see no translated strings for this plugin).

This ticket was mentioned in Slack in #meta by tellyworth. View the logs.


7 months ago

This ticket was mentioned in Slack in #meta by tellyworth. View the logs.


3 months ago

This ticket was mentioned in Slack in #meta by zodiac1978. View the logs.


3 months ago

#6 @tellyworth
7 weeks ago

  • Keywords needs-patch added
  • Priority changed from normal to high

This ticket was mentioned in Slack in #polyglots by sergey. View the logs.


2 weeks ago

#8 @tellyworth
2 weeks ago

I believe this is working now, or at least vastly improved. As of [6198] and a subsequent reindex, https://cn.wordpress.org/plugins/search/自定义微信分享/ shows the wx-custom-share plugin as the second result, which looks about right to me.

This ticket was mentioned in Slack in #meta by tellyworth. View the logs.


2 weeks ago

#10 @Otto42
2 weeks ago

  • Resolution set to fixed
  • Status changed from reopened to closed

This seems provisionally fixed, for now. Further changes will address the translations propagation, but those are best covered in other tickets.

This ticket was mentioned in Slack in #meta by joostdevalk. View the logs.


6 days ago

Note: See TracTickets for help on using tickets.