WordPress.org

Making WordPress.org

Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#2826 closed defect (fixed)

Plugin Directory: Data not syncing/updating properly from SVN commits

Reported by: brianhogg Owned by:
Milestone: Priority: highest omg bbq
Component: Plugin Directory Keywords:
Cc:

Description

After 27 hours the wordpress.org listing still doesn't show the latest update. This is fine and can happen when the servers are overloaded.

However, WordPress sites with the plugin are showing that an update is available. The new update details do not appear when "view version details" is clicked, and trying to update results in "Update Failed: Download failed. Not Found"

If the update cannot be downloaded, it should not be shown in WordPress sites. 'Update available' should be the last thing to be updated after the zip has been generated.

Attachments (2)

Screenshot 2017-05-14 12.58.05.png (33.6 KB) - added by brianhogg 2 years ago.
Screenshot 2017-05-14 12.56.20.png (66.0 KB) - added by brianhogg 2 years ago.

Download all attachments as: .zip

Change History (7)

#1 @pigeonhut
2 years ago

Same happening for me across 2 plugins updated yesterday and today, have also had clients opening support tickets for it

#2 @Ipstenu
2 years ago

  • Priority changed from high to highest omg bbq
  • Summary changed from Download failed, not found error when plugin update out of sync to Plugin Directory: Data not syncing/updating properly from SVN commits

We're doing a mass import to try and catch everyone, but this is going to take a while.

I'm leaving this open so people can report more issues here, as it's basically ALL related to the sync jobs that run after you commit code to SVN. They're not behaving. Server team is looking, but it's Sunday :/

Issues you MAY be experiencing:

  • Version numbers not updating
  • Versions updating, but downloads failing
  • Downloads failing for SOME people

In all cases, PLEASE DO NOT SUBMIT MULTIPLE UPDATES. You probably didn't do anything wrong, so just give it a while :/ It will work out but it's going to be slow until we figure out what broke.

#3 @Otto42
2 years ago

  • Resolution set to fixed
  • Status changed from new to closed

The problems with our scheduler appear to have been fixed now, and the queue length has returned to normal levels. The issue was not specific to plugin updates, but plugin updates were the most obvious side-effect.

We will continue to monitor the situation, and we have setup automatic alerts in case things go wrong again.

#4 @brianhogg
2 years ago

@Otto42 After pushing an update today to The Events Calendar Shortcode, sites were showing the update as available but when trying to update you get a "Update Failed: Plugin update failed." message. After about 15 minutes it cleared up and the updates went through.

Is this a related issue or should I open a new ticket?

#5 @Otto42
2 years ago

@brianhogg It is a related issue, and we know the cause. It will be fixed soon, but in the meantime, that window you noticed tends to be much shorter, on the scale of 2-3 minutes or so. The window will disappear entirely when the underlying problem is corrected.

Note: See TracTickets for help on using tickets.