WordPress.org

Making WordPress.org

Opened 2 years ago

Closed 15 months ago

#2831 closed defect (fixed)

On the Advanced view of a plugin the list of committers is imporperly formatted.

Reported by: aguseo Owned by: obenland
Milestone: Plugin Directory v3 - Future Priority: normal
Component: Plugin Directory Keywords: has-screenshots ui-feedback reporter-feedback needs-testing has-patch
Cc:

Description

On the Advanced view of a plugin the list of committers is cascading vs being under each other.

Screenshot here: https://cloudup.com/c_eWP58vjh5

It could be fixed with a bit of css like this:

.committer-list li {
    clear: both;
    margin-bottom: 0.5rem;
}

Attachments (2)

2831.diff (214.6 KB) - added by fischfood 20 months ago.
CSS changes for Committer's List, increasing bottom padding
2831_v2.diff (214.8 KB) - added by fischfood 20 months ago.
CSS Styles - Reverting Padding changes, changing to min-height to work with admin users

Download all attachments as: .zip

Change History (11)

#1 follow-up: @Ipstenu
2 years ago

  • Keywords reporter-feedback added

@aguseo - what plugin is that on? And what browser/OS are you on.

I can't reproduce that view.

#2 in reply to: ↑ 1 @aguseo
2 years ago

Replying to Ipstenu:

@aguseo - what plugin is that on? And what browser/OS are you on.

I can't reproduce that view.

Hi @Ipstenu,

Sorry, I should have shared the link upfront.
I found it on these urls so far:
https://wordpress.org/plugins/gigpress/advanced/
https://wordpress.org/plugins/event-tickets/advanced/
https://wordpress.org/plugins/image-widget/advanced/
https://wordpress.org/plugins/advanced-post-manager/advanced/

I'm contributor to these plugins.
It only seems to be like that when I'm logged in. That is when I see the committers list where this glitch happens. When I'm logged out I don't see committers.

I'm using Windows 7 / 10 and Firefox 52 / 53, chrome 58.0.3029.110 (64-bit), IE11.

I hope this helps, let me know if you need more info.
Cheers

#3 @Ipstenu
2 years ago

Oooh.

So mine won't look like that when logged in because I'm an admin, and I have an extra line below it (for the email addresses).

Interesting... I'm torn between "You shouldn't see committers at all if you're not a committer of that plugin" and "We should fix that!"

#4 @karmatosed
23 months ago

I also wonder how useful this information is if you are just a user/viewer. Don't we need to fix though then for someone who is? It seems a less optimal visual experience otherwise.

#5 @SergeyBiryukov
20 months ago

#3050 was marked as a duplicate.

@fischfood
20 months ago

CSS changes for Committer's List, increasing bottom padding

#6 @fischfood
20 months ago

  • Keywords needs-testing added

@fischfood
20 months ago

CSS Styles - Reverting Padding changes, changing to min-height to work with admin users

#7 @fischfood
20 months ago

I reverted the padding back to 0.5rem, since 1rem made it rather large for admin users of that plugin (since the remove link is there). Setting the min-height and inline-block lets the items stack for contributors that aren't committers, while keeping the committers view to normal sized spacing.

Last edited 20 months ago by fischfood (previous) (diff)

#8 @tellyworth
18 months ago

  • Keywords has-patch added

#9 @obenland
15 months ago

  • Owner set to obenland
  • Resolution set to fixed
  • Status changed from new to closed

In 6467:

Plugins: Properly clear committer list items.

Props aguseo, fischfood.
Fixes #2831.

Note: See TracTickets for help on using tickets.