WordPress.org

Making WordPress.org

Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#2836 closed defect (fixed)

Plugin favorites no longer showing on main Plugin Directory page

Reported by: ahortin Owned by: Otto42
Milestone: Plugin Directory v3.0 Priority: normal
Component: Plugin Directory Keywords: has-patch
Cc:

Description

Up until recently there was a link to your saved plugin favorites at the bottom of the main plugin directory page on WordPress.org. This link used to appear after the list of Featured & Popular plugins, but it no longer exists.

This means that you can no longer get to your plugin favorites (when logged in), from the main plugin page. The only way to get to your favourites is by viewing your profile page, or by using one of the Featured/Popular links and then selecting the Favorites link.

Can you please fix the plugin directory page so that this link is available as it was previously.

Thanks.

Attachments (1)

2836.patch (1.9 KB) - added by SergeyBiryukov 2 years ago.

Download all attachments as: .zip

Change History (9)

#1 @ahortin
2 years ago

  • Summary changed from Plugin favorites no longer showing on main Plugin Direcotry page to Plugin favorites no longer showing on main Plugin Directory page

#2 @ocean90
2 years ago

  • Keywords needs-patch added
  • Milestone set to Plugin Directory v3.0

Broken since [5500]. The query on the front page isn't the main query so the custom query vars don't get applied.

This ticket was mentioned in Slack in #meta by tellyworth. View the logs.


2 years ago

@SergeyBiryukov
2 years ago

#4 @SergeyBiryukov
2 years ago

  • Keywords has-patch added; needs-patch removed

2836.patch replaces [5500] with a more targeted fix.

Double-checked to make sure it doesn't introduce any regressions in #2594 or #2787.

Last edited 2 years ago by SergeyBiryukov (previous) (diff)

This ticket was mentioned in Slack in #meta by sergey. View the logs.


2 years ago

This ticket was mentioned in Slack in #forums by clorith. View the logs.


2 years ago

#7 @Otto42
2 years ago

  • Owner set to Otto42
  • Resolution set to fixed
  • Status changed from new to closed

In 5532:

Plugin Directory: Add My Favorites back to main page. Fixes #2836. props @SergeyBiryukov

#8 @ahortin
2 years ago

Fantastic! Thanks for fixing that.

Note: See TracTickets for help on using tickets.