WordPress.org

Making WordPress.org

Opened 23 months ago

Closed 17 months ago

Last modified 15 months ago

#2856 closed enhancement (maybelater)

Popular Tags back on the WordPress.org Directory

Reported by: florinmuresan Owned by:
Milestone: Priority: normal
Component: Plugin Directory Keywords:
Cc:

Description

User don’t have access to the Popular tags anymore on the Wordpress.org directory. That makes it harder for them to find what they need.

From the statistics of our plugin if we take all the popular tags out of our readme file. Very few people find the plugin even if it ranks on the first position on several keywords.

If we put them back they find us mostly on the popular tags you can now find in the Feature section of the Dashboard.

If users who search for plugins use this feature they should have access to it in the Wordpress Directory as well, as they could in the past.

It is helpful especially for new Wordpress users that don’t know what are all the aspects they should be focusing on. Therefore, without the suggestions given by popular tags regarding what they could search for, their experience could be ruined. (as compared to wp veterans who already know what plugins to search for).

Images here:http://www.florinmuresan.com/wp-content/uploads/2017/06/11-pic-26.pnghttp://www.florinmuresan.com/wp-content/uploads/2017/06/11-pic23.png
http://www.florinmuresan.com/wp-content/uploads/2017/06/11-pic-30.png

Change History (21)

#1 @Clorith
23 months ago

Hiya,

I don't agree that the tags are beneficial to end users, as they are more likely to use a search, writing what they want to do more so than click through a bunch of keywords hoping to find what they don't know they need.

You'll notice that using the tags links in the sidebar of a plugin now, takes you to the search results page using the tag as the search term, and not a dedicated tag list as well for this reason.

I'll also leave a note of this core ticket proposing the removal of the tag list in core as well.

#2 @florinmuresan
23 months ago

Yes, I agree that the tag cloud isn't the best part of the UI. However, it's an important part of the user experience.

We took out our tags to experiment with this. In the days when we didn't have tags we received about 40 new users / day. Then, we've placed tags that made sense and were ALSO shown there in the tag cloud. We started getting 70 new users / day.

And before, when you could look at the tags in the left menu of the plugin directory we had 150 new users / day.

That's almost 4 times more than what you'd get via keyword search. Which is pretty much solid evidence that people searching the directory actually use the tags.

Please bear in mind that WordPress.org is used by many non-developers who count on it to find new plugins. Out typical users install 20 plugins on average for each of their sites. Of course, if you are a developer placing plugins for your clients you need what to search for.

For all the rest of them, this isn't a valid point. They need to be able to find out what kind of cool things other people try to find on the WordPress directory. And thus, they end up discovering cool things to try out.

#3 @Ipstenu
23 months ago

Thank you for documenting your experiment! That's very helpful to have something that we can reproduce to test.

#4 @florinmuresan
23 months ago

You're welcome, Mika! If you want I can send you a more detailed file that has Actions taken / day vs New Users that day.

We've played a bit with optimizing for keywords and tags and you could see what we did.

#5 @petrizzo
23 months ago

Hi,

I use wordpress as end user and also as developer. I'm mostly "visual". I think that popular tags helps users like me to quickly find out not only the latest plugins but also the tags with more plugins available.

That's why I whant "popular tags" back

Please consider it.

Mariángela

#6 @venturavan2
22 months ago

Hey, Long time member. 73 wordpress sites of my own and manage many others. Whenever I visit WordPress.org it is first from my admin panel then sometimes a personal visit to search for plugins or themes. The tags are CRUCIAL. I now find I have to leave my admin panel almost 80% of the time to find something I am looking for. I blame that directly on the missing tags. Please bring them back.

I also agree that the tags are IMPERATIVE for newbies.

Happy Father's Day

Van Hallman

#7 @Ipstenu
22 months ago

@venturavan2 - The tag cloud that was removed was not on the wp-admin back end anyway, so it shouldn't impact your searches. While your statement is accurate, that it's harder for you to find plugins now, its also really anecdotal. That is to say, it sounds like the SEARCH is not working properly.

Can you help us and explain in detail? A good example would be if you could tell us what plugin you were looking for, HOW you looked (that is what you entered into the search field for the plugins) and what results you saw? That way we can test and hopefully reproduce and fix things :)

#8 @NextScripts
22 months ago

@Ipstenu It's not about "Search", it's more about "Research".

"Search" means you are looking for what you already know exists.

Tags were helping to discover the things that you might not even know existed, but will be very helpful to you. Browsing tags cloud was a great way to discover the new possibilities of using WP. Now it's gone.

#9 @Ipstenu
22 months ago

Browsing tags cloud was a great way to discover the new possibilities of using WP.

Now that's interesting. Though it doesn't (appear to) address the issue the previous poster mentioned, it's certainly a use-case I'd not considered. Probably because I see so many new plugins, but I just always assume "you can do anything with WP, so someone probably has." Thank you!

This ticket was mentioned in Slack in #accessibility by sergey. View the logs.


22 months ago

#11 @SergeyBiryukov
22 months ago

  • Summary changed from Popular Tags back on the Wordpress.org Directory to Popular Tags back on the WordPress.org Directory

#12 @preston41
22 months ago

Another vote for the return of the Popular Tags cloud.

Look at those plugins that have less than 10 installs, they are not all rubbish. Most users simply just cannot find them. They do not pop up. Not every developer is good at marketing and has a blinging website pointing wordpress users to the directory.

Sort it out Wordpress.

Last edited 22 months ago by preston41 (previous) (diff)

#13 @tellyworth
18 months ago

  • Milestone Plugin Directory v3.0 deleted
  • Resolution set to maybelater
  • Status changed from new to closed

This is something that needs to be done in conjunction with a cleanup or smarter processing of tags. Maybe ES can help with that.

#14 @florinmuresan
17 months ago

  • Resolution maybelater deleted
  • Status changed from closed to reopened

#15 @florinmuresan
17 months ago

  • Milestone set to Plugin Directory v3.0

I do not agree. As you could see here in the thread there are others who do not agree with the way things are right now after the event of Popular Tags removal.

It's just an UI issue, so it should be easily fixed. Please take due time to consider that many developers with 100 active installs are at the moment discouraged to keep their work alive because not enough people use what they've created.

As someone mentioned above: these people are great developers. They can't be great marketing magicians as well who know what keywords they should place to be found via keyword search. they also don't know how to gain more downloads. They think that by building something great people would use it.

And that story was true during the Popular Tags period. Find a way to bring them back.

#16 @Ipstenu
17 months ago

  • Milestone Plugin Directory v3.0 deleted
  • Resolution set to maybelater
  • Status changed from reopened to closed

@florinmuresan Please leave this as maybe later. We can still talk about it, but the status is to clearly indicate we're not working on it at the moment.

This is something that needs to be done in conjunction with a cleanup or smarter processing of tags. Maybe ES can help with that.

That's why this is maybe later. Tags are useless to use as 'popular' if they're a free for all, so they need to be cleaned up to be valuable.

Your presumption that popular tags made better plugins show up higher in search or get found easier is interesting, but I don't know of any metrics to prove it one way or another (except from people who paradoxically ARE marketing experts and are shocked to find out keyword stuffing is bad...).

#17 @florinmuresan
17 months ago

Okay, sounds fair. The important thing for tags will be to provide a way to surface unpopular plugins that you wouldn't find via search (due to being unpopular at the moment). And to provide a way to discover plugins based on things people care about: twitter, email, social media, ecommerce, sales, cache, security, conversion, editor, etc.

That way they could browse those tags and find cool new plugins they'd never thought of finding before.

Yes, I am a marketing expert.

No, I am not shocked at all that keyword stuffing is bad. It's the reason why one of our plugins warns against it and tells the user to write better and really focus on the Human audience.

#18 @Ipstenu
17 months ago

But by that logic, all popular (i.e. used) tags would tell you are the things that are popular and you would find by being searched....

Right now there are 56,529 different tags. The most popular ones are...

  • widget - 4,398
  • post - 2,517
  • woocommerce - 2,398
  • admin - 2,379
  • posts - 1,842

I don't know that listing popular ones would help here :/ One of our original ideas was a curated list of tags, but that got shot down.

#19 @florinmuresan
17 months ago

Why did it get shot down? It seems like a good idea:

twitter, email, social media, ecommerce, sales, cache, security, conversion, editor, gallery, short code, side bar

And more ideas could be curated and shown. These would all be good to show, to let people know what types of plugins they could get. Or for which kinds of things (not the best writing ever) there already are plugins developed on WordPress. This could even solve the problem of not having categories of plugins available. (like you have categories which you can browse to discover apps on AppStore or Google Play)

To curate tags would seem a better alternative to just showing the ones you've mentioned.

This ticket was mentioned in Slack in #accessibility by afercia. View the logs.


15 months ago

#21 @afercia
15 months ago

Would be nice to coordinate future changes here with the related core ticket https://core.trac.wordpress.org/ticket/40186

Note: See TracTickets for help on using tickets.