WordPress.org

Making WordPress.org

Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#2868 closed defect (duplicate)

Pagination of Plugins on wordpress.org

Reported by: kadiwala Owned by:
Milestone: Priority: normal
Component: Plugin Directory Keywords:
Cc:

Description

Hi,

* I found a very basic issue on wordpress.org site.

  • There is issue at pagination on plugins page of wordpress.org site.

Above link is working perfectly, But when next button is clicked after 99th page then next page gives an error - "404 Not Found"

  • If there is no page after 99th page then i think it is not required to display additional links of page.
  • If pages available then why that page gives an error ?

---
Thanks & Regards
Aakif Kadiwala

Change History (2)

#1 @Otto42
2 years ago

  • Resolution set to maybelater
  • Status changed from new to closed

This is intentional. Those pages past 99 do exist, but virtually no real users go that far into the pagination. However, search engines do go there and get really aggressive about it on WordPress.org, which causes us lots of load problems.

So, this is a temporary measure, but it is by design. The measure may be removed in the future when the directory has some more optimizations made to it.

#2 @SergeyBiryukov
2 years ago

  • Component changed from General to Plugin Directory
  • Keywords #pagination removed
  • Priority changed from high to normal
  • Resolution changed from maybelater to duplicate

Duplicate of #496.

Note: See TracTickets for help on using tickets.