WordPress.org

Making WordPress.org

Opened 2 years ago

Closed 10 months ago

#2895 closed defect (duplicate)

Sponsor invoice notification emails come from wrong address

Reported by: iandunn Owned by:
Milestone: Priority: low
Component: WordCamp Site & Plugins Keywords: needs-patch good-first-bug
Cc:

Description

The email notifications that get sent when a sponor invoice is updated sometimes come from the wrong email address. For example, a notification about an invoice for 2017.seattle.wordcamp.org might be sent from 2017.brisbane.wordcamp.org (or any other site in the network).

​I think that's happening because, by default, wp_mail() sets the Message.From based on the current site, and that notification is triggered by a cron job, so the current site is just whichever site happened to be visited at the moment the job was scheduled.

Assuming that's the problem, we should be able to fix it by explicitly setting the From header to EMAIL_CENTRAL_SUPPORT in wp-content/plugins/wordcamp-payments-network/includes/sponsor-invoices-dashboard.php::notify_organizer_status_changed().

Change History (3)

#1 @iandunn
2 years ago

  • Owner set to iandunn
  • Status changed from new to accepted

#2 @iandunn
22 months ago

  • Owner iandunn deleted
  • Status changed from accepted to assigned

#3 @iandunn
10 months ago

  • Resolution set to duplicate
  • Status changed from assigned to closed

Duplicate of #3190.

Note: See TracTickets for help on using tickets.