WordPress.org

Making WordPress.org

Opened 2 years ago

Closed 2 years ago

#2919 closed defect (fixed)

broken shortcodes at the “Development” page

Reported by: bestwebsoft Owned by: tellyworth
Milestone: Plugin Directory v3.0 Priority: high
Component: Plugin Directory Keywords: needs-testing dev-feedback has-patch
Cc:

Description

Hello, Team!

We have already reported the issue about the broken shortcodes at the “Development” page of Subscriber plugin (https://ru.wordpress.org/plugins/subscriber/#developers) twice in your translators blog starting from Jun 07. The ploblem appears when switching to the Russian language (http://prntscr.com/fiw05y).
We followed the advice and rejected the translation of the string containing “or” but the problem still remains. In fact, we don’t have any shortcodes translated, even partial. Please help us with this issue.

Attachments (2)

2919.patch (1.0 KB) - added by SergeyBiryukov 2 years ago.
2919.2.patch (1.4 KB) - added by SergeyBiryukov 2 years ago.

Download all attachments as: .zip

Change History (10)

#1 @SergeyBiryukov
2 years ago

To clarify a bit, the issue is caused by the "or" string translation.

In Russian, "or" is translated to "или", which breaks the plugin directory shortcodes:

  • [wporg-plugins-reviews] becomes [wpилиg-plugins-reviews].
  • [wporg-plugins-developers] becomes [wpилиg-plugins-developers].

Random string parts shouldn't be translated like that, only the whole strings should be.

#2 follow-up: @bestwebsoft
2 years ago

We have already rejected “or” string translation for about 2 or 3 weeks ago (http://prntscr.com/fr22cp). The problem is still there. Could you please advise our further actions?

Last edited 2 years ago by bestwebsoft (previous) (diff)

#3 in reply to: ↑ 2 @SergeyBiryukov
2 years ago

Replying to bestwebsoft:

We have already rejected “or” string translation for about 2 or 3 weeks ago.

The first translation was rejected by @fierevere on June 7th, but on June 9th you've submitted a new translation, which reintroduced the bug.

The problem is still there. Could you please advise our further actions?

I'd suggest waiting until @ocean90 can take a look.

Last edited 2 years ago by SergeyBiryukov (previous) (diff)

This ticket was mentioned in Slack in #polyglots by sergey. View the logs.


2 years ago

This ticket was mentioned in Slack in #meta by sergey. View the logs.


2 years ago

#6 @SergeyBiryukov
2 years ago

  • Keywords has-patch added

@SergeyBiryukov
2 years ago

#7 @SergeyBiryukov
2 years ago

2919.2.patch takes word boundaries into account, so that strings inside shortcodes are not randomly replaced.

#8 @tellyworth
2 years ago

  • Owner set to tellyworth
  • Resolution set to fixed
  • Status changed from new to closed

In 5736:

Plugin directory: prevent very short translations from interfering with shortcodes. Props @SergeyBiryukov.

Fixes #2919

Note: See TracTickets for help on using tickets.