WordPress.org

Making WordPress.org

Opened 2 years ago

Closed 7 months ago

#2977 closed defect (fixed)

Search is not using translations (no localized search possible)

Reported by: agilelogix Owned by: gibrown
Milestone: Plugin Directory v3.0 Priority: high
Component: Plugin Directory Keywords: needs-patch
Cc:

Description

I want to report some ranking issue in locales of the English version, the plugin directory ranking change in locales (en-gb, en-ca, en-au), all the languages are almost same as they are English but the ranking is not same. Please have a look at this problem.

Example:

https://wordpress.org/plugins/search/Store+Locator/
https://en-gb.wordpress.org/plugins/search/Store+Locator/

Both the searches are same but results are different in locales, I don't understand this, as both languages are in English.

Thank you

Change History (29)

#1 @SergeyBiryukov
2 years ago

  • Component changed from General to Plugin Directory

#2 in reply to: ↑ description @SergeyBiryukov
2 years ago

Replying to agilelogix:

Both the searches are same but results are different in locales, I don't understand this, as both languages are in English.

en_US and en_GB are different locales though.

Looks like there are 153 waiting strings for Agile Store Locator's readme in en_GB. Once those strings are approved by the en_GB team, I guess the plugin should rank higher for that locale.

#3 @agilelogix
2 years ago

Hi @SergeyBiryukov 100% approved for en-ca, but the result is same.

https://en-ca.wordpress.org/plugins/search/store+locator/

Please check this.

Thanks

#4 @agilelogix
2 years ago

  • Priority changed from normal to high

#5 @zodiac1978
2 years ago

I was wondering about this search issue as well.
The ranking is totally different between international and local (e.g. German) directories.

For example the plugin “Advanced Ads” is not on the first page here:
https://de.wordpress.org/plugins/search/adsense/
but here on 5th place:
https://wordpress.org/plugins/search/adsense/

Although it is the only one with a German translation, which is contrary to the the assumption from @SergeyBiryukov that this should have a positive effect.

If I search for translated text from the readme it doesn’t find the plugin at all:
https://de.wordpress.org/plugins/search/anzeigentypen/
or
https://de.wordpress.org/plugins/search/anzeigen/

Seems to be a bigger problem with non-US directories and ranking in general.

#6 @zubairharoon
2 years ago

Yes, indeed there is a problem in locale directory searching, the algorithm is not working properly for locale searching, we have to wait for someone to take it and fix it.

#7 @SergeyBiryukov
2 years ago

We've noticed a similar issue in Russian directory a while ago: https://wordpress.org/plugins/search/reviews/ and https://ru.wordpress.org/plugins/search/reviews/ return different results.

I assumed it was due to translations being one of the ranking factors, but none of the first few plugins have a Russian translation, so I'm not sure what else affects the results on localized directories.

#8 follow-up: @ocean90
2 years ago

Related: #1496, #2812

Afaik there is still nothing that fills the search index with new translations.

This ticket was mentioned in Slack in #meta-i18n by sergey. View the logs.


2 years ago

#11 in reply to: ↑ 8 @zodiac1978
2 years ago

Replying to ocean90:

Afaik there is still nothing that fills the search index with new translations.

What does that actual mean? And if this is the reason, who can fix this? I read the backlogs from the slack meetings the last times, but this (high priority!) ticket doesn't get mentioned at all.

Is there a roadmap when this Plugin Directoty v3 issues get tackled (or should get tackled)? Maybe @tellyworth can clarify this a bit?

This ticket was mentioned in Slack in #meta by zodiac1978. View the logs.


2 years ago

This ticket was mentioned in Slack in #meta by otto42. View the logs.


2 years ago

#14 @afercia
2 years ago

Following today's conversation on Slack and just to add one more example: searching for "Yoast" on the default locale, "Yoast SEO" is the first result:
https://wordpress.org/plugins/search/yoast/

Same search with the Italian locale, "Yoast SEO" is in the 5th page:
https://it.wordpress.org/plugins/search/yoast/
https://it.wordpress.org/plugins/search/yoast/page/5/

Instead, the first result in the first page is "ACF Content Analysis for Yoast SEO" and seems to me it's not translated in Italian.

#15 @ocean90
2 years ago

  • Keywords dev-feedback added
  • Owner set to gibrown
  • Status changed from new to reviewing

@gibrown Can you review please?

#16 @gibrown
2 years ago

Ya, the issue here is that the translations are not getting properly synced, so for some reason Yoast does not have any translations, and so it is getting ranked much lower.

I think @tellyworth was looking into this problem, but I am not sure where it is at.

This ticket was mentioned in Slack in #meta by zodiac1978. View the logs.


2 years ago

#18 @zodiac1978
2 years ago

  • Keywords needs-patch added
  • Summary changed from wordpress.org and locale such as en-gb, en-ca and en-au ranking doesn't match to Search is not using translations (no localized search possible)

This ticket was mentioned in Slack in #meta by gibrown. View the logs.


23 months ago

#20 @tellyworth
23 months ago

This should be partially improved in [6197] - in that revision all en_* locales should produce identical results.

This ticket was mentioned in Slack in #meta by zodiac1978. View the logs.


15 months ago

#22 @tellyworth
15 months ago

  • Resolution set to fixed
  • Status changed from reviewing to closed

In 7478:

Plugin dir: sync translated content to postmeta. Props @noisysocks

This runs the Translation_Sync cron job periodically.

Fixes #3169
Fixes #2977

#23 @ocean90
15 months ago

In 7479:

Revert [7478] due to out of memory errors.

See #2977.

#24 @ocean90
15 months ago

  • Keywords dev-feedback removed
  • Resolution fixed deleted
  • Status changed from closed to reopened

Reverted [7478] in [7479].

E_ERROR: object-cache.php:228 - Allowed memory size of 268435456 bytes exhausted (tried to allocate 67108872 bytes)

#25 @webzunft
13 months ago

Any chance my team and I can help with this? We tried to reproduce it locally, but are missing the information used in Elasticsearch and the real database information. Any idea how we can simulate that?

Thanks

This ticket was mentioned in Slack in #forums by zodiac1978. View the logs.


10 months ago

#27 @zodiac1978
9 months ago

After six months this is still unfixed, although people are providing to help. @tellyworth, @noisysocks and @ocean90 - what is planned to fix this after the last patch was reverted because of the memory problem?

This ticket was mentioned in Slack in #meta-i18n by dd32. View the logs.


9 months ago

#29 @tellyworth
7 months ago

  • Resolution set to fixed
  • Status changed from reopened to closed

In 8461:

Plugin directory: fix memory consumption issue in translation sync and re-enable cron job.

$wp_object_cache->group_ops was growing unbounded. Also cleaned up related PHP notices caused by undefined values in stats array.

Fixes #2977

Note: See TracTickets for help on using tickets.