WordPress.org

Making WordPress.org

Opened 9 months ago

Closed 4 months ago

#3083 closed defect (fixed)

wordpress.tv subscribe Sign me up button text color not readable .

Reported by: mp518 Owned by: obenland
Milestone: Priority: normal
Component: WordPress.tv Keywords: has-patch
Cc:

Description

Now button text color black so not readable it should be white so button looks like good.

Attachments (3)

notreadable.PNG (14.2 KB) - added by mp518 9 months ago.
before
afterchanges.PNG (13.5 KB) - added by mp518 9 months ago.
after change
3083.patch (768 bytes) - added by mp518 9 months ago.
remove !important

Download all attachments as: .zip

Change History (11)

@mp518
9 months ago

before

#1 @mp518
9 months ago

div#actionbar .actnbr-notice form button {
	background: #00aadc;
	border-color: #008ab3;
	color: white !important;
	border-style: solid;
	border-width: 1px 1px 2px;
	cursor: pointer;
	display: inline-block;
	margin: 0;
	outline: 0;
	overflow: hidden;
	font-weight: 500;
	text-overflow: ellipsis;
	text-decoration: none;
	vertical-align: top;
	box-sizing: border-box;
	font-size: 14px;
	line-height: 21px;
	border-radius: 4px;
	padding: 7px 14px 9px;
	-webkit-appearance: none;
	-moz-appearance: none;
	appearance: none;
	font-family: inherit;
	text-transform: none;
	-webkit-font-smoothing: auto;
	height: auto;
	line-height: 1;
}

@mp518
9 months ago

after change

#2 @SergeyBiryukov
9 months ago

  • Component changed from General to WordPress.tv

#3 @SergeyBiryukov
9 months ago

If anyone else is having a trouble finding this form on WordPress.tv (took me a few minutes), it's at the bottom right of the page when you're logged out.

Caused by color: #555 !important (and color: #000 !important for :hover) in wptv2/style.css:

input[type=submit], button, .button {
	...
	color: #555 !important;
	...
}

input[type=submit]:hover, button:hover, .button:hover, input[type=submit]:focus, button:focus, .button:focus {
	...
	color: #000 !important;
	...
}
Last edited 9 months ago by SergeyBiryukov (previous) (diff)

#4 @SergeyBiryukov
9 months ago

  • Keywords needs-patch added

Removing the !important fixes the issue, but it's not quite clear why it was added in the first place. In [1024] it was already there.

If anyone wants to take a stab at the patch, the theme is here: sites/trunk/wordpress.tv/public_html/wp-content/themes/wptv2/.

@mp518
9 months ago

remove !important

#5 @mp518
9 months ago

  • Keywords has-patch added; needs-patch removed

Yes @SergeyBiryukov if remove !important than issue fix. In this patch 3083.patch ​i have removed because it not needed to add !important.

Last edited 9 months ago by mp518 (previous) (diff)

This ticket was mentioned in Slack in #wptv by casiepa. View the logs.


7 months ago

This ticket was mentioned in Slack in #meta-wordcamp by iandunn. View the logs.


7 months ago

#8 @obenland
4 months ago

  • Owner set to obenland
  • Resolution set to fixed
  • Status changed from new to closed

In 6384:

WordPress TV: Don't style wpcom subscribe button.

Stops overly important styles from intruding on non-theme UI elements.

Props mp518, SergeyBiryukov.
Fixes #3083.

Note: See TracTickets for help on using tickets.