WordPress.org

Making WordPress.org

Opened 2 years ago

Closed 9 months ago

#3084 closed defect (worksforme)

Translate API endless loop

Reported by: casiepa Owned by:
Milestone: Priority: normal
Component: Translate Site & Plugins Keywords:
Cc:

Description

https://translate.wordpress.org/api/projects/wp is responding correctly
https://translate.wordpress.org/api/projects is not

It seems to go in an endless loop and then ends with an ERR_TOO_MANY_REDIRECTS

Attachments (1)

Ticket 3084 Endless redirection.png (68.4 KB) - added by tobifjellner 9 months ago.
The issue is still there. Opening https://translate.wordpress.org/api/projects/ in Firefox on Windows

Download all attachments as: .zip

Change History (6)

#1 @SergeyBiryukov
2 years ago

Looks like it redirects to /api/projects/ (note the trailing slash) and back to /api/projects until the limit is reached. I'm not familiar with the API part of GlotPress yet, but sounds like a bug to me :) It should either display the projects or show an error, but not fall into an endless redirect loop.

#2 @dd32
23 months ago

FWIW The redirect from /api/projects/ to /api/projects is being triggered by redirect_canonical().

I can't trigger the /api/projects to /api/projects/ in my development environment either, so I'm not sure what's up.

The /api/projects route definitely isn't one we want to allow to be loaded though, as it causes OOM errors. IIRC we may have even disabled it directly - @ocean90 do you recall anything about this one?

#3 @ocean90
23 months ago

The API routes for projects are not disabled, see https://meta.trac.wordpress.org/browser/sites/trunk/wordpress.org/public_html/wp-content/plugins/wporg-gp-routes/inc/class-plugin.php#L106. We probably should, /api/projects/wp-plugins is killing it.

I couldn't reproduce this on my sandbox neither last time I checked. So maybe there's another redirect rule (nginx) somewhere. By default all URLs should be without a trailing slash.

@tobifjellner
9 months ago

The issue is still there. Opening https://translate.wordpress.org/api/projects/ in Firefox on Windows

This ticket was mentioned in Slack in #meta by tobifjellner. View the logs.


9 months ago

#5 @ocean90
9 months ago

  • Resolution set to worksforme
  • Status changed from new to closed

Seems to work now.

Note: See TracTickets for help on using tickets.