WordPress.org

Making WordPress.org

#3097 closed enhancement (duplicate)

Add a report mistake button to Translation editors UI

Reported by: danieltj Owned by:
Milestone: Priority: normal
Component: Translate Site & Plugins Keywords:
Cc:

Description

Sometimes when going through and translating projects, you might seem a string in the plugin (or theme) that has a spelling/grammar error in it. At the moment it sort of depends on your own opinion and that of the Locale team as to what you should do. I propose a new button for the UI that allows you to mark a translatable string or current translation as incorrect.

This should then provide some UI feedback (potentially an email as well) to the plugin/theme author that there is an incorrect string that needs fixing. This would ensure that strings are spelt correctly and also people are not translating incorrect strings regularly.

I'd suggest the feedback of incorrect strings would sit on the Translation side of things and not cross over into the plugin/theme directory itself. Lastly, my current opinion is anyone can mark something as incorrect but only editors and authors of said package can see what is currently marked as such.

Thoughts on this?

I'd like to see a defined way of reporting such errors keeping inline with the current workflow of translations.

Change History (1)

#1 @ocean90
20 months ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #1162.

Note: See TracTickets for help on using tickets.