WordPress.org

Making WordPress.org

Opened 20 months ago

Closed 20 months ago

Last modified 20 months ago

#3099 closed enhancement (wontfix)

Plugin languages should go to the GlotPress page instead of Rosetta site

Reported by: danieltj Owned by:
Milestone: Priority: normal
Component: Plugin Directory Keywords:
Cc:

Description

Just recently the plugin directory has had the languages added to the sidebar so you can quickly see what languages the plugin is available in. When you click to expand the popup box it lists the languages and the href for these is the plugin on each Rosetta site.

Since the list of available languages has moved from the Development tab onto the sidebar, there doesn't seem to be an easy way to view the project on translate.wordpress.org anymore. I'd suggest that The links take you there instead of (in some cases) refreshing the Rosetta site.

Attachments (1)

plugin-dir-locales.jpg (234.1 KB) - added by danieltj 20 months ago.
Example on the plugin page.

Download all attachments as: .zip

Change History (3)

@danieltj
20 months ago

Example on the plugin page.

#1 @ocean90
20 months ago

  • Resolution set to wontfix
  • Status changed from new to closed

Thanks for your feedback but that's by design.

will take you to the same page

It's not really the same page, it may be in another variant of English, but not if you're using one the major languages like Japanese, Spanish or German.

there doesn't seem to be an easy way to view the project on translate.wordpress.org anymore.

Nothing has changed in that regards. The Development (and Contributors) tab still shows the information for contributors. There's also a language banner if you have set a language that is passed to the Accept-Language HTTP header.

#2 in reply to: ↑ description @SergeyBiryukov
20 months ago

Replying to danieltj:

Since the list of available languages has moved from the Development tab onto the sidebar, there doesn't seem to be an easy way to view the project on translate.wordpress.org anymore.

I think adding a "Translate ... into your language" link under the list of languages would be helpful, created #3100 for that.

Note: See TracTickets for help on using tickets.