Making WordPress.org

Opened 5 years ago

Closed 8 months ago

#3107 closed defect (bug) (worksforme)

Plugin Directory: Changelogs not updating on Rosetta plugin directories, Act II

Reported by: let-me-see's profile let me see... Owned by:
Milestone: Priority: normal
Component: Plugin Directory Keywords: 2nd-opinion
Cc:

Description (last modified by SergeyBiryukov)

On WP MS German install, the changelog for plugin updates is almost always one version behind (today: Yoast 5.4 update available, changelog in my backend says 5.3.3 is latest)

Very similar problem to this ticket: #2750

Change History (8)

#1 @SergeyBiryukov
5 years ago

  • Description modified (diff)

This ticket was mentioned in Slack in #meta by sergey. View the logs.


5 years ago

#3 follow-up: @zodiac1978
5 years ago

@SergeyBiryukov Isn't the plugin details page in the WP backend cached locally? I see this very often too and had a short talk with @obenland on this topic. I am wondering because if I see there is an update I should see the correct changelog, but I see an old one. Not sure if this is a problem with the translated version, local cache or something else.

#4 in reply to: ↑ 3 ; follow-up: @SergeyBiryukov
5 years ago

Replying to zodiac1978:

Isn't the plugin details page in the WP backend cached locally?

The API request is performed by plugins_api() via install_plugin_information(), I don't see any caching there at a glance.

#5 in reply to: ↑ 4 @zodiac1978
5 years ago

Replying to SergeyBiryukov:

The API request is performed by plugins_api() via install_plugin_information(), I don't see any caching there at a glance.

Then what could be the reason for this behavior? I get a notice about a plugin update, click the details link to open the modal and get an old changelog info. If I switch to the page in the plugin directory there is the newest changelog info and sometimes the info is on local version of the plugin directory (and sometimes not).

I would expect to see the current information in my backend, if I get an update notice. If there is a cache it should be invalidated. If not, I have no clue what the reason of this issue can be ... any ideas?

#6 @swissspidy
5 years ago

Then what could be the reason for this behavior?

Caching on the API server I suppose.

#7 @obenland
4 years ago

Is there a current example we could use to troubleshoot?

#8 @dd32
8 months ago

  • Resolution set to worksforme
  • Status changed from new to closed

Due to the age of this ticket, and lack of further reports in the last 5 years, I'm marking this as worksforme.

I've done some testing, and I can't reproduce it on a number of popular plugins, and those updated within the last few hours.

If this is still being experienced by anyone, I'd like to hear further details

Note: See TracTickets for help on using tickets.