WordPress.org

Making WordPress.org

Opened 3 months ago

Closed 2 months ago

#3110 closed defect (fixed)

Don't say "plugin is not available" when it is available for downloads

Reported by: Shelob9 Owned by: SergeyBiryukov
Milestone: Plugin Directory v3.0 Priority: normal
Component: Plugin Directory Keywords:
Cc:

Description

Currently in localized versions of plugin repo, if a plugin is available for download, but isn't translated fully in that language, it says "This plugin is not available in yet. Help translate it!" This is misleading, since it makes it seem as if the plugin is not available.

I've had several people tell me they havn't tried my plugin because it isn't available in their country, for example Great Britain.

I would suggest that changing this message to:

"This plugin is not translated in this language, yet. Help translate it!" would be more clear and convey the actual message of what isn't done and why help is needed.

Change History (4)

#1 @Presskopp
3 months ago

  • Milestone Plugin Directory v3.0 deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #2618.

#2 @SergeyBiryukov
3 months ago

  • Component changed from General to Plugin Directory

#3 @SergeyBiryukov
2 months ago

  • Milestone set to Plugin Directory v3.0
  • Resolution duplicate deleted
  • Status changed from closed to reopened

To clarify a bit, "This plugin is not available in yet" message is a bug (as described in #2618). There should be a language name in there, e.g. "This plugin is not available in English (UK) yet".

That said, it does sound a bit confusing. "This plugin is not translated into English (UK) yet" would indeed be more accurate.

#4 @SergeyBiryukov
2 months ago

  • Owner set to SergeyBiryukov
  • Resolution set to fixed
  • Status changed from reopened to closed

In 6032:

Plugin Directory: In locale banner, replace "This plugin is not available in [language] yet" message wording with "This plugin is not translated into [language] yet" for clarity.

Props Shelob9.
Fixes #3110.

Note: See TracTickets for help on using tickets.