WordPress.org

Making WordPress.org

Opened 4 years ago

Closed 2 years ago

#315 closed enhancement (duplicate)

add search box to each plugin´s support forum to search within existing support threads only

Reported by: harmr Owned by:
Milestone: Priority: normal
Component: Support Forums Keywords:
Cc:

Description

I am more and more answering the same questions on my support forum at http://wordpress.org/support/plugin/leaflet-maps-marker
Often, new threads could be avoided if users had the chance to search only within the existing support threads of my plugin.
If the are using the general search on http://wordpress.org/support/ they might not always get the relevant results if they dont
add the specific keywords (like "why does my map not show up?" might bring results from other mapping plugins too).

Currently on http://wordpress.org/support/plugin/leaflet-maps-marker there is only the search box "Search plugin" left to the threads.
It would be really useful if an additional search box like "search within existing threads" could be added above the list of topics in
the center. This search box could only be visible if at least 1 support thread exists.

I also added a quick mockup which displays what I mean (please be aware that I am no designer ;-)http://i61.tinypic.com/10xat8w.png

Change History (6)

#1 @jmanko
3 years ago

This is an absolute must. I'm just dumbfounded that this hasn't been implemented. I bet if you put poll on the plugin support page asking if this would be a useful feature, you'd probably get nearly 100% support for it.

Adding this is a no-brainer.

#2 follow-up: @Ipstenu
3 years ago

It's not easy is why it's not done yet. The forums will need a full overhaul and upgrade to bbPress 2.x to make it possible, and that has to coincide with the upgrade for themes and plugin's (in progress) and we have to make sure all our tools that were hand written for this instance still work. Most need a total rewrite.

So ... It's not that we don't all agree, it's that this is a part of a bigger issue that just adding in one feature.

#3 in reply to: ↑ 2 ; follow-up: @kidsguide
3 years ago

  • Cc mpsplugins@… added

Replying to Ipstenu:

The forums will need a full overhaul and upgrade to bbPress 2.x to make it possible, and that has to coincide with the upgrade for themes and plugin's (in progress)...

Can this not be included in the WP.org Forums Plugins Audit (https://make.wordpress.org/meta/2015/05/15/wp-org-forums-plugins-audit/)?

#4 in reply to: ↑ 3 @netweb
3 years ago

Replying to kidsguide:

Replying to Ipstenu:

The forums will need a full overhaul and upgrade to bbPress 2.x to make it possible, and that has to coincide with the upgrade for themes and plugin's (in progress)...

Can this not be included in the WP.org Forums Plugins Audit (https://make.wordpress.org/meta/2015/05/15/wp-org-forums-plugins-audit/)?

Those plugins are a list of what's currently being used with bbPress 1.x and for determining which plugins need to be upgraded to support bbPress 2.x and is not needed there because bbPress 2.x includes search out of the box and a plugin is not needed.

#5 @Deborahjb
2 years ago

+1 for this!!

#6 @SergeyBiryukov
2 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #7.

Note: See TracTickets for help on using tickets.