WordPress.org

Making WordPress.org

Opened 3 years ago

Closed 3 months ago

Last modified 3 months ago

#3215 closed defect (fixed)

Zero themes shown on English variations of the Theme Directory

Reported by: johnbillion Owned by: dd32
Milestone: Priority: high
Component: Theme Directory Keywords: needs-patch
Cc:

Description

When searching for "wordpress themes" on google.co.uk, the top result points to https://en-gb.wordpress.org/themes/ which simply shows a No themes found error message. Sad times.

Change History (14)

#1 @johnbillion
3 years ago

Huh, this appears to be an intermittent error. It doesn't actually happen every time.

#2 @Otto42
3 years ago

It is a known issue that the theme directory occasionally, and rarely, shows only one theme. It's a caching problem which is difficult to track down. Never seen it show zero themes though.

#3 @obenland
2 years ago

In 6546:

Themes: Add debug snippet to track 1 theme result

See #3215.

This ticket was mentioned in Slack in #meta by sergey. View the logs.


11 months ago

This ticket was mentioned in Slack in #themereview by dingo_d. View the logs.


8 months ago

#6 @dingo_d
8 months ago

@obenland Did you get any debug info about this?

#7 @obenland
8 months ago

So far I haven't gotten anything, no

#8 @dingo_d
8 months ago

I'm all for closing this then :)

#9 @dd32
8 months ago

Given this is a known issue, that's still occuring (even if we've not been able to catch it with debug code) it's probably best to leave this open until it ceases to happen / be reported.

#10 @dd32
3 months ago

In 9524:

Theme Directory: Add some debugging to try to figure out the cause of none, or 1 theme only showing up on the Theme Directory homepage.

See #3215.

#11 @dd32
3 months ago

In 9525:

Theme Directory: Revert Debug added in r9524.

See #3215.

#12 @dd32
3 months ago

  • Owner set to dd32
  • Resolution set to fixed
  • Status changed from new to closed

In 9526:

Theme Directory: Don't use the global $wp_query object when querying themes.

This was causing cached results to be affected by other query params that WP_Query accepts through $_GET.

This will cause an increase in queries on same pages, but should be unnoticed thanks to the heavy caching we employ on these pages.

Debug left in to ignore caches with only 1 result, can be removed in a few hours after all caches expire.

Fixes #3215.

This ticket was mentioned in Slack in #themereview by dd32. View the logs.


3 months ago

#14 @dd32
3 months ago

In 9527:

Theme Directory: remove the now not-needed cache debugging code.

See #3215.

Note: See TracTickets for help on using tickets.