WordPress.org

Making WordPress.org

#3223 closed enhancement (duplicate)

Personalized Schedule Builder for WordCamp Attendees

Reported by: iandunn Owned by:
Milestone: Priority: high
Component: WordCamp Site & Plugins Keywords: needs-patch good-first-bug
Cc:

Description

The [schedule] shortcode displays a static schedule to attendees (e.g., https://2017.seattle.wordcamp.org/schedule/). Many attendees would like to pick out sessions in advance, and build a simpler schedule of just those sessions, rather than having to refer to the full schedule all the time.

Background info and discussion.

v1 of this tool should let them:

  1. Explore the session and speaker details without navigating away from the app
  2. Let them select the sessions they want to attend
  3. Save those selections in their browser (cookie, local storage, etc)
  4. Let them export the schedule to other devices, like a phone or tablet. Maybe email them a link w/ a hash parameter that contains the data required to rebuild the schedule on the new device. The data should then be saved on the new device.
  5. Have a print button and print stylesheet.
  6. Maintain backwards compatibility with the existing [schedule] shortcode. This is strongly preferred, but not required if there isn't a good way to do it. Explore the possibilities and post some preliminary notes here to discuss it with other developers before getting too far into the project.

This is a large enough project that it should follow the feature implementation guidelines.

Sharing schedules and generating PDFs should be out of scope for v1, but could be v2 features.

Change History (1)

#1 @iandunn
18 months ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #2733.

Note: See TracTickets for help on using tickets.