WordPress.org

Making WordPress.org

#3226 closed defect (fixed)

JavaScript breaks registration flow Using CampTix Indian Payments

Reported by: codexdemon Owned by:
Milestone: Priority: highest omg bbq
Component: WordCamp Site & Plugins Keywords: has-patch
Cc:

Description

The camptix-multi-popup.js only applies to Razorpay currently, but it gets enqueued no matter which of the gateways are enabled. When Instamojo is the only enabled payment method, the script can prevent the Register button from submitting the form successfully.

This bug was discovered on the WordCamp Nashik 2017 site, which is using Instamojo, but not Razorpay.

To reproduce:
Enable Instamojo, but not Razorpay
On the front end Tickets page, apply a coupon
Then click the Register button to start the checkout process
Clicking the button will cause the viewport to scroll down the Tickets page a ways, but otherwise do nothing.

Suggested fix:

The quickest fix is to detect whether Razorpay is enabled, and only enqueue the script if it is. However, since it's possible that both Razorpay and Instamojo (and other future gateways added to the plugin) could all be enabled at the same time, a better fix would be to refine the script so that it only captures the Register button when completing the checkout using Razorpay.

Attachments (1)

3226.patch (13.8 KB) - added by codexdemon 18 months ago.
Fixed Issue blocking registration on Word Camp Nashik

Download all attachments as: .zip

Change History (4)

@codexdemon
18 months ago

Fixed Issue blocking registration on Word Camp Nashik

#1 @SergeyBiryukov
18 months ago

  • Milestone Plugin Directory v3.0 deleted

This ticket was mentioned in Slack in #meta-wordcamp by sanyog. View the logs.


18 months ago

#3 @iandunn
18 months ago

  • Resolution set to fixed
  • Status changed from new to closed

This was fixed by upgrading to version 1.6.

xref https://github.com/wpindiaorg/camptix-indian-payments/issues/41

Note: See TracTickets for help on using tickets.