WordPress.org

Making WordPress.org

Opened 20 months ago

Closed 19 months ago

Last modified 18 months ago

#3316 closed defect (fixed)

Confusing calls to action on main Download WordPress page

Reported by: bamadesigner Owned by: obenland
Milestone: Priority: normal
Component: General Keywords:
Cc:

Description

Almost every time I’m on the [Download WordPress](https://wordpress.org/download/) page I click the "Download WordPress" button in the header which does nothing because it’s a link to the page I’m viewing. The call to action I should be driven to is the "Download WordPress" button in the body of the page.

The issue is that the both calls to action are practically identical and placed near each other on the screen.

One fairly simple solution would be to remove the “Download WordPress" button from the header when you’re on the download page.

Attachments (1)

Screen Shot 2017-12-07 at 12.58.53 PM.png (327.1 KB) - added by bamadesigner 20 months ago.
Screenshot of the Download WordPress page with confusing calls to action highlighted

Download all attachments as: .zip

Change History (5)

@bamadesigner
20 months ago

Screenshot of the Download WordPress page with confusing calls to action highlighted

This ticket was mentioned in Slack in #design by melchoyce. View the logs.


20 months ago

#2 @obenland
19 months ago

@bamadesigner it turns out, you're in good company. 98.7% of visitors on that page do the same.

Version 0, edited 19 months ago by obenland (next)

#3 @obenland
19 months ago

  • Owner set to obenland
  • Resolution set to fixed
  • Status changed from new to closed

In 6332:

WP4: Don't show Download button on download page

98.7% of visitors use it to reload the page, trying to download WordPress.

Fixes #3316.

#4 @bamadesigner
18 months ago

Thanks @obenland!

Note: See TracTickets for help on using tickets.