WordPress.org

Making WordPress.org

#3379 closed defect (duplicate)

Support Forums: Respect `filter` parameter when doing a redirect for plugin reviews

Reported by: SergeyBiryukov Owned by:
Milestone: Priority: normal
Component: Support Forums Keywords:
Cc:

Description

Background: #WP43016

Before the upgrade to bbPress 2.x, plugin reviews had URLs like this:

https://wordpress.org/support/view/plugin-reviews/product-name?filter=1

They are still linked to from WordPress admin (as of 4.9.1).

After the upgrade, the URLs have changed to:

https://wordpress.org/support/plugin/product-name/reviews/?filter=1

There is a redirect in Directory_Compat::request(), but it does not respect the filter parameter.

Change History (1)

#1 @Otto42
20 months ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #3376.

Note: See TracTickets for help on using tickets.