WordPress.org

Making WordPress.org

Opened 4 months ago

Closed 3 months ago

Last modified 3 months ago

#3447 closed defect (fixed)

Plugin Stats Report broken since BB1 was deleted

Reported by: Ipstenu Owned by:
Milestone: Priority: high
Component: Plugin Directory Keywords:
Cc:

Description

Related to #1726

https://wordpress.org/plugins/wp-admin/tools.php?page=statsreport is used to generate the statistics on plugin reviews. This was working but broke in the end of January.

Per @dd32

It’s using a stats system that was never implemented in the new directory it seems. stats_extras – which seems to be only interacted with by old bbPress installs.
Either the stats report needs to be updated to query the WordPress tables, or stats_extras needs to be implemented into the new directory..

The old bbPress directory was still working up until the 22nd when the /plugins/ bbPress install was removed.

This is preventing us from being able to chart... well ... anything.

@coffee2code wrote the original.

(it would also be nice to not have to manually count the rejected plugins, but I can live with that ;) )

Change History (9)

#1 @Otto42
4 months ago

NM, I see the page now and what's missing. Okay.

#2 @dd32
3 months ago

In 6874:

Plugin Directory: First attempt at fixing the plugin stats report.

See #3447.

#3 @dd32
3 months ago

[6874] is the first attempt at fixing this, some of the numbers seem off, I'm not sure if I've got an off-by-one day in there, or if it was just caused by #3511 causing the data it's pulling from being invalid.

I added the closure reason count to the list, as AFAIK those are now public?

#4 @dd32
3 months ago

In 6875:

Plugin Directory: Stats Tool: Switch the plugins requested stat to using the _submitted_date postmeta, seems like it'll be a more accurate data field.

See #3447.

#5 follow-up: @Ipstenu
3 months ago

I added the closure reason count to the list, as AFAIK those are now public?

Not really but it doesn't matter to anyone but me at the moment :) It's fine as is!

(Trac didn't email me about this... thanks trac)

#6 in reply to: ↑ 5 @dd32
3 months ago

Replying to Ipstenu:

I added the closure reason count to the list, as AFAIK those are now public?

Not really but it doesn't matter to anyone but me at the moment :) It's fine as is!

(Trac didn't email me about this... thanks trac)

@Ipstenu Would you be able to 'gut check' it, make sure the numbers feel right? Given you've posted the update, I assume the numbers looked right?

The numbers felt right to me, and I didn't dig into it too deeply to check they were indeed correct (As that's next to impossible..) but they seemed within what I'd call expected.

I added the closure reason count to the list, as AFAIK those are now public?

Not really but it doesn't matter to anyone but me at the moment :) It's fine as is!

I figured that even if they weren't public, having that as a stat for yourself might have been useful :)

#7 @Ipstenu
3 months ago

The numbers were super close to the notebook I was using to keep track ... and constantly forgot to mark things in, so it sure feels right.

Plugins closed : 52 felt high until I saw that I'd closed a lot of plugins for being unused, and I know _exactly_ what user that was for :D

Thumbs up.

#8 @dd32
3 months ago

  • Resolution set to fixed
  • Status changed from new to closed

@Ipstenu Great! Thanks :)

If there's any stats which you think would be good to track, please feel free to create a ticket for it

This ticket was mentioned in Slack in #meta by tellyworth. View the logs.


3 months ago

Note: See TracTickets for help on using tickets.