WordPress.org

Making WordPress.org

#3455 closed task (invalid)

Add New Onboarding/Concierge Team

Reported by: danieltj Owned by:
Milestone: Priority: normal
Component: General Keywords:
Cc:

Description

I'd like to propose a new team for the community in the form of an on-boarding/welcoming type of team focused on getting new contributors involved in the project (in any particular way that might be). I myself felt that when I first started getting involved that it was tricky to find the right information and there was a lot to take in. It can be very overwhelming to get going properly.

That's why I'd like to have a new team added and head it up but encouraging people to get involved and providing assistance in the various ways they can get involved.

Whilst this team would in some way extend other teams, I don't feel like onboarding necessarily needs to come from a specific team like Core, or Themes, or Marketing. With a new team we can be much more specific in helping guide people into the project, explain how things work. Help people get setup and next steps.

Perhaps this could even be expanded to having some kind of mentorship programme as well. I'm keen to try and help more people get involved where possible and make that first contribution a lot easier.

Change History (17)

#1 follow-up: @ocean90
18 months ago

  • Keywords close added

This should better be posted on https://make.wordpress.org/community/.

#2 in reply to: ↑ 1 @danieltj
18 months ago

Replying to ocean90:

This should better be posted on https://make.wordpress.org/community/.

I'll reach out the community team. Initially my reasoning for proposing a new team was I felt this extended beyond the community team as this is more on-boarding and it seems the community team focus more so on WordCamps etc which is why I think this would be better off as a new team. I'll reach out though.

This ticket was mentioned in Slack in #community-team by danieltj. View the logs.


18 months ago

#4 @danieltj
18 months ago

  • Keywords close removed

@hlashbrooke from the Community Team has suggested to keep it here for a few more opinions to weigh in.

Read the Slack messages.

So just to reiterate, this team's focus would in theory reach beyond the community team and in fact all teams as the idea is that it focuses on contributing to the overall WordPress project, and helping people get started in any of the teams going forward. Not just at WordCamps or the initial contribution. It would also not stop at new people to the WordPress project, but existing contributors wanting to take a different approach.

Whilst I appreciate that bits here and there might already be covered, I think a dedicated team would help pool resources together and focus on this area of actual on-boarding which has been brought up before as being tricky to really get stuck. I think this bridges a gap and would benefit the community as a whole.

I'm removing the close tag so we can get some more opinions from people.

#5 @ocean90
18 months ago

  • Keywords close added

Yet it's about the community so I don't see why an initial posts on make/community is wrong. The Make sites are far, far better than Trac for discussions. Trac should only be used for technical implementations.

#6 @SergeyBiryukov
18 months ago

Sounds like a great idea to me. I guess there might be some overlap with the Community Team, but as pointed out, it extends a bit beyond the team's focus, so having a dedicated onboarding team for all the various ways of contributing to WordPress seems beneficial.

Let's post this on make/community though for more visibility :)

#7 @xkon
18 months ago

@SergeyBiryukov that was my thought as well and just for reference and to avoid double posts, there's already a reply on tomorrow's #community-team meeting at https://wp.me/p2U65r-4p2 just in case a discussion about it can start at some point in the near future :) .

#8 @obenland
18 months ago

  • Resolution set to maybelater
  • Status changed from new to closed

Yes, let's keep meta tickets for things that need changing on Meta. It looks like there is already an agenda item for it at the next community meeting, let's discuss it there and come back if Meta changes are necessary.

#9 @danieltj
18 months ago

  • Keywords close removed
  • Resolution maybelater deleted
  • Status changed from closed to reopened

After much discussion in #community (+ P2 post) and also in #marketing, whilst there has been some points raised that there will be overlap, points have also been raised about how it's necessary and valid for a new team to operate even with the efforts that other teams are currently doing.

Please can a new team be created on the Make site for Make WordPress Welcoming, (Welcoming Team) please? There are quite a few people who have stepped forward and said they'd be interested in helping. I'd like to lead the team but closely with aid from the people who have expressed an interest in it.

Overall, the biggest concern we've had is that there would be a slight overlap in team operations, however myself, and others who have expressed an interest in this team have duly noted that the direct impact of this team is not covered by other teams at the moment. I definitely see potential for close working with other teams, namely Marketing however the sole purpose isn't covered by what the Marketing team already do.

The vision for this new team is to be the first port of call for new contributors wanting to get involved. Guides on what to do and where to go to do contributions (which Marketing have worked on) will be essential. Support on how to get environments setup to be contribution ready for WordPress. Possibility of mentoring programmes for continued support for contributors wanting to get heavily involved with things like core contributions and feature projects. Not to mention, generally working closely with other teams to ensure it's easy to join in and help.

I do also see the need for a new forum in the support forums at some point, however that isn't something that would be necessary to begin with. Our approach is fairly simple though; make WordPress more welcoming to new contributors who want to get involved but don't know how. Whilst this can be done at WordCamps with a contributor day, it's usually not enough to ensure people are setup correctly and ready to start committing to a project, whether it's code, designs or ideas. So this team would play an instrumental part in every other team currently available.

:)

#10 @netweb
18 months ago

As I've already mentioned in the past couple of days in both the #marketing and #community channels that it was only in the past week or so that what I perceived the #marketing team to be all about was drastically changed after reading a few of the team meeting notes at https://make.wordpress.org/marketing/, they are already working on two onboarding guides that I know of "Navigating Trac guide for new people" and "WP Jargon Glossary for new people" and a heap of other awesome projects but they are off-topic and unrelated for this post.

Having an onboarding sub-team of the #marketing team to at least experiment with and to iterate on the current projects and then to create further onboarding projects would be great to see before creating another team to do what one team has already begun undertaking.

It would be great to see you build on that prior work @danieltj and if that work is not ideally suited to the #marketing team then the option of creating a new dedicated team can be raised again.

Version 1, edited 18 months ago by netweb (previous) (next) (diff)

#11 @danieltj
18 months ago

My only push back on the sub-team as part of Marketing is that they are focusing on writing the content that can be used by others (and this new team) whereas the focus here is to actually put the content they've created into place and guide people on what to do and what resources they need (ones written by Marketing).

That's my only concern, is that it seems a little out of scope to me in terms of starting off as a sub-team. I know @bridgetwillard and @mcdwayne have both weighed in on the discussion and raised very valid points. If that's a route that needs to be taken, I'm happy to take it. I just want to ensure that we take an approach that suits everyone and fits in with the missions the teams are set out with, that's all.

This ticket was mentioned in Slack in #meta by gidgey. View the logs.


18 months ago

#13 @danieltj
18 months ago

Posting on behalf of @bridgetwillard from Slack:

The Marketing Team no longer has subgroups. It took us a year to merge, we’d prefer to stay united.

Messages on #meta

I think the best approach is to set-up a new team independent of #marketing and #community.

#14 @netweb
18 months ago

Don't make it a sub-team then, join the #marketing team and help them out on the existing onboarding projects they are currently working on. If that work then outgrows the marketing team revisit creating a new team then.

#15 @obenland
18 months ago

I think I agree with @netweb here. "Usually" (if creating a new team is even usual to begin with) I'd assume a team would be created because their efforts outgrow the boundaries of an existing team and need more room.

Currently I don't see a reason why a group of folks focused on Welcoming couldn't get started as part of the community or marketing team and use their P2 for updates, announcements, etc. If Marketing is already working on onboarding-related efforts, it feels to me like a natural fit and something that could be combined with this effort and expanded.

While I do feel like onboarding should be something that's embedded in the individual teams, I don't feel as strongly about adding a dedicated slack channel fwiw.

#16 @xkon
18 months ago

Having a completely different team for just Welcoming and giving tips and pointers to new people wouldn't make much of a difference and could make things even more complicated as yes a 'welcome' team per say would be overstepping everywhere.

The idea as I see it comes down to having 1 extra slack chat room that doesn't have rules on asking questions ( I mean no offense but for example WordPress core development. NOT for support or general chatting. I mean for a chat exactly the opposite of this ), for example everybody that joined slack could go on #welcome, or #general-help ( you can name it whatever ) and that could be a free-for-any-question-24/7 chat used by the welcome people who basically are all of us who don't mind being bombarded with questions all the time :D .

You'll tell me now that all of this already happens in all chat rooms and yes it does with 1 difference, usually in all existing team channels you'll see a question and then a link to a HandBook maybe? The problem is that HandBooks are sometimes difficult for some people to understand no matter how clean & correct they are. So they just need a live-chat with somebody to have feedback and to help them step by step or give some pointers instead of reading a doc posted online. Let's say pretty much like a live-chat Support Team would do?

Think of it like the new-contributors chat on #core but daily 24/7 for all questions and all aspects of wp.org on contributing.

As I see it this way:

1] There's always a chat full of new people that usually have the same questions.
2] The team chatrooms will be even more clean from random questions here and there so they can focus more on contributing and dealing with bugs / fixes.
3] People will feel like the whole community from all teams are welcoming them aboard not only #core or #forums or #design individually.

If you say that IRC was made to facilitate this kind of 'chat' then not many people use IRC these days anymore, maybe it's time to bring a chatty chatroom on slack so people can just ask anything anytime.

I might be going off from the original proposal but a Welcoming person does only 1 thing, says welcome and gives directions, nothing else. There's no need for a team, or for an extra p2 or for an extra forum or anything imho. Just a simple chat for live interaction & feedback.

#17 @danieltj
18 months ago

  • Resolution set to invalid
  • Status changed from reopened to closed

Well the idea is that it's a new team with a P2 and forum etc to allow a wider reach of people to get support with getting involved and a Slack channel, whilst it'd be great to have, is only part of the scope here so just having a channel and nothing else bypasses the bigger issue here I feel.

I'll close this and perhaps the other teams can continue with their strategy and see where it goes. As Marketing are already writing documentation to aid this I feel it might be the most suitable path for now.

Note: See TracTickets for help on using tickets.