WordPress.org

Making WordPress.org

#3549 closed enhancement (duplicate)

Meetings : Add shared calendar feed

Reported by: mindmantra Owned by:
Milestone: Priority: normal
Component: Make (Get Involved) / P2 Keywords: needs-patch
Cc:

Description

It gets tricky to keep oneself informed about team meetings listed in https://make.wordpress.org/meetings/

While having this page makes things smoother, it is still not widely consumable and doesn't support any notifications or highlights changes/deviations. So any deviation/change in meetings can not be communicated to users unless they manually check the change or read post, if any, in Make blog.

An ideal solution would be to have a shared calendar feed so one can easily integrate it with their choice of calendar solution.

I propose to use widely supported iCal format to create such feed.

But this needs considerations on below issues:

  1. How many previous and future meetings should be included in feed?
  2. Should it follow current meeting page? Then is it wise to remove all the events other than those published?
  3. Should recurring meetings be marked as recurring? If yes, then how to tackle future updates or one-off changes?
  4. Have static .ics file generated post each edit and served from uploads folder? or have a dynamic URI/end-point and let caching mechanism handle generated feed?

Change History (2)

#1 @Otto42
15 months ago

Dupe of #2955. Will mark as such when trac is fixed.

#2 @762e5e74
15 months ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #2955.

Note: See TracTickets for help on using tickets.