WordPress.org

Making WordPress.org

Opened 4 years ago

Closed 4 years ago

#357 closed enhancement (duplicate)

Add minimal support to the WordCamp Base theme to allow CSS overrides to be fully responsive

Reported by: r3df Owned by:
Milestone: Priority: normal
Component: WordCamp Site & Plugins Keywords: has-patch
Cc:

Description

To create a fully responsive CSS override for WordCamp Base, a bit of JavaScript is needed to create an open/close toggle for a responsive menu that is touch screen friendly. Ideally an HTML element for the the toggle button is also needed.

This patch takes the approach from twentytwelve and adapts it to WordCamp Base. The file navigation.js is copied from twentytwelve and adjusted for the different tags in the HTML in WordCamp Base.

An H3 element is added above the menu, as it is in twentytwelve. The element is hidden by default by CSS.

The patch does not yet include all the language file updates for the word "Menu" that has been added.

Change History (1)

#1 @r3df
4 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #358.

Note: See TracTickets for help on using tickets.