WordPress.org

Making WordPress.org

Opened 14 months ago

Last modified 10 months ago

#3604 reopened defect

Translated plugin states 'This plugin is not translated into en_CA yet'

Reported by: garrett-eclipse Owned by:
Milestone: Priority: normal
Component: Plugin Directory Keywords:
Cc:

Description

Hello,

I've had Wordfence translated for quite some time but whenever I access the plugin page I find the notice;
"This plugin is not translated into English (Canada) yet. Help translate it!"

Plugin Page - https://en-ca.wordpress.org/plugins/wordfence/

But if you look on translate that locale is 100% and has been for a while (months).
https://translate.wordpress.org/projects/wp-plugins/wordfence

Thanks

Attachments (2)

Screen Shot 2018-05-03 at 10.32.47 AM.png (347.6 KB) - added by garrett-eclipse 14 months ago.
Wordfence Plugin Page
Screen Shot 2018-05-03 at 10.32.56 AM.png (158.9 KB) - added by garrett-eclipse 14 months ago.
Wordfence Translations

Download all attachments as: .zip

Change History (7)

@garrett-eclipse
14 months ago

Wordfence Translations

#1 @ocean90
14 months ago

  • Component changed from Translate Site & Plugins to Plugin Directory
  • Resolution set to invalid
  • Status changed from new to closed

The readme is, but in this case it's about the plugin itself which is sadly not properly prepared for localization. I suggest to contact the plugin author.

#2 @garrett-eclipse
14 months ago

Thanks @ocean90 I didn't realize it was the plugin itself that was a requirement. I've spoken to them before and they're looking into for the future but isn't pressing to them.
I guess the main confusion from a user perspective is going through that link expecting something to translate and finding 100% can be confusing. Can that message be updated when plugin doesn't support localization?

#3 @SergeyBiryukov
14 months ago

The page already says "This plugin is not properly prepared for localization", though I guess the notice could be missed. Maybe it should be red instead of orange?

Or maybe the symbol in Development and Stable columns should be changed to 0% for clarity?

#4 @garrett-eclipse
14 months ago

Thanks @SergeyBiryukov the messaging on the translation page is great. My confusion was more when you're on the plugin page;
"This plugin is not translated into English (Canada) yet. 'Help Translate It'"
https://meta.trac.wordpress.org/raw-attachment/ticket/3604/Screen%20Shot%202018-05-03%20at%2010.32.47%20AM.png

This caused me to hop through the link to translate it which is where I found and realized the cause being it not prepared. So if anything the messaging on the plugin page itself could reflect the fact it's not able to be translated due to it not properly being prepared. That way I don't bother diving into the translation as whenever I see that link on a plugin I use I want to go and translate it.

Something like;
"This plugin is not translated into English (Canada) because it's not properly prepared for localization."
*Then drop the link as there's no point trying to 'Help Translate It'

Thanks again,
Cheers

Last edited 14 months ago by garrett-eclipse (previous) (diff)

#5 @garrett-eclipse
10 months ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

Reopening to have my last comment taken into account.

Note: See TracTickets for help on using tickets.