WordPress.org

Making WordPress.org

Opened 2 years ago

Last modified 4 months ago

#3674 new defect

Forums: pending replies do not send notification after reviewed

Reported by: mariovalney Owned by:
Milestone: Priority: low
Component: Support Forums Keywords:
Cc:

Description

When a reply is pending on Support Forum no notifications are sended.
It's OK but I guess it should trigger a notification when it's published.

Change History (3)

This ticket was mentioned in Slack in #forums by clorith. View the logs.


4 months ago

#2 @Clorith
4 months ago

I'm not sure if this is a good way forward.

If, for example, Akismet flagged something, then there's a high likelihood that the user receiving an email with the same content later will also view it as spam and mark it as such.
Email services work off reputation these days, and we don't want to risk sending content which may be perceived as spam to users.

As for flagged accounts, they are users who have had a behavior that means we want to keep an eye on them, and the notifications being blocked is part of that task, so that we're certain what information ends up where from a potential bad actor.

#3 @mariovalney
4 months ago

A user who subscribed for a topic (and most important: the author) is waiting for notifications about new content. So it's not spam even sending it later.

If the answer is not OK for forums will not be published, so OK not sending notification.

EDIT: I checked now the discussion on Slack.

First I was thinking about the answers that fall on spam by mistake (if you point a lot of links for docs, for example) but your concern about the mail vendors is a very good point. Maybe we can send a notification with a (not so) generic text pointing to a new answer?

Last edited 4 months ago by mariovalney (previous) (diff)
Note: See TracTickets for help on using tickets.