WordPress.org

Making WordPress.org

Opened 12 months ago

Closed 12 months ago

Last modified 12 months ago

#3731 closed task (wontfix)

Remove the `Preview` button

Reported by: acosmin Owned by:
Milestone: Priority: high
Component: Theme Directory Keywords:
Cc:

Description

Seeing how theme authors have no access/control on how the Previewer displays a theme, this causes more problems than it solves.

Even if we have better test data, the Previewer will not be able to display the full potential of a theme.

An option would be to add a tag in style.css, something like no-previewer and the button disappears.

Just to be sure :) an off site link to a demo is off the table? We currently allow a Theme and Author URL and any ill-intentioned author can do the damage there.

We could also ask if theme authors want this in a make blog post by adding a poll and maybe take that into consideration.

Change History (13)

#1 @bothera
12 months ago

Love the idea, there is so many issues caused by the previewer (Just look at the #themereview on Slack today).
This would solve pretty much all of them :-)

This ticket was mentioned in Slack in #themereview by acosmin. View the logs.


12 months ago

#3 @acosmin
12 months ago

We could start with the theme pages on .org, the preview option in the WP Administration Panel is a bit tricky, implies Core changes and the only solution there would be to remove the button and only preview the theme if it's installed (or just use screenshots)

Last edited 12 months ago by acosmin (previous) (diff)

#4 @rinkuyadav999
12 months ago

Theme author defines Theme URI in style.css file. similarly they can define Demo URI. if w.org script found Demo URI, it will use it for preview otherwise current previewer will display preview. in this case, we just need to do small changes in script and nothing will affect. it will much better and theme demo link issue will be also fixed.

#5 follow-ups: @poena
12 months ago

-1
If theme authors cant make the theme look good with any type of generic content then to be honest its not a very good theme.
Theme authors dont know what type of content the user has.

Last edited 12 months ago by poena (previous) (diff)

#6 in reply to: ↑ 5 @machothemes
12 months ago

Replying to poena:

-1
If theme authors cant make the theme look good with any type of generic content then to be honest its not a very good theme.
Theme authors dont know what type of content the user has.

You must be thinking about simple, blogging themes with just a handful of blog posts. Real themes nowadays are way more complex and can't be demo'ed just with "generic content".

+1 for this.

#7 in reply to: ↑ 5 ; follow-up: @DannyCooper
12 months ago

+1

Compare the current preview to a real demo, even for the default themes:

Preview: https://wp-themes.com/twentyseventeen/
Demo: https://2017.wordpress.net/

Replying to poena:

-1
If theme authors cant make the theme look good with any type of generic content then to be honest its not a very good theme.
Theme authors dont know what type of content the user has.

#8 in reply to: ↑ 7 ; follow-up: @rinkuyadav999
12 months ago

Replying to DannyCooper:

+1

Compare the current preview to a real demo, even for the default themes:

Preview: https://wp-themes.com/twentyseventeen/
Demo: https://2017.wordpress.net/

Nice example +1

#9 in reply to: ↑ 8 @bothera
12 months ago

Agree +1

Replying to rinkuyadav999:

Replying to DannyCooper:

+1

Compare the current preview to a real demo, even for the default themes:

Preview: https://wp-themes.com/twentyseventeen/
Demo: https://2017.wordpress.net/

Nice example +1

#10 @Otto42
12 months ago

  • Resolution set to wontfix
  • Status changed from new to closed

No. The previewer will remain, as will the button to view it. Improvements to the previewer will be ongoing, but removing it as an option is not on the table.

#11 @greenshady
12 months ago

It's not that previewer issues can't be fixed. It's that the team has never been given the greenlight or the means to address those issues. Over the years, the theme team has come up with several ideas.

When we talk about generic content not being good enough to show off modern themes, that's not the crux of the issue. 95% (totally made up but probably close to accurate percentage) of the problem with the previewer boils down to the following. I've ordered these things from what I think are the most to least important.

  • The post content should be representative of real-world user content. And, there should be a lot more of it.
  • There needs to be a good set of featured images that are dynamically resized per the theme's requested image size.
  • The previewer doesn't let themes show off their custom front page template (see: https://make.wordpress.org/themes/2015/08/20/proposal-better-front-page-previews/).
  • Mark at least one post sticky.
  • Expose the customizer to the user.

The team has been told that a multisite install where authors control their demos and an external preview link are both off the table. So, addressing the above seems like the best course of action.

The previewer doesn't have to show everything a theme can do. However, it should at least give some idea of what the theme looks like.

I understand where the frustration comes from and why some want to just get rid of it altogether. The TRT is tired of being the bad guy when theme authors find ways to target the preview system on .ORG to make their themes look prettier. It's one of those soul-sucking responsibilities that makes me happy to have stepped away from a team lead position.

#12 @kevinhaig
12 months ago

1++++

Theme preview pain (pun intended) has never represented what a theme can do. It is a colossal waste of resources.

Over the years, we have as theme reviewers have spent much time defending abuse of the preview pane by authors who just want to have their themes show what their themes can really do.

I think a plugin type repo with multiple screenshots would be much better.

This ticket was mentioned in Slack in #themereview by dannycooper. View the logs.


12 months ago

Note: See TracTickets for help on using tickets.