WordPress.org

Making WordPress.org

Opened 12 months ago

Closed 11 months ago

Last modified 9 months ago

#3779 closed defect (fixed)

WordPress.tv video is overlapping content

Reported by: karmatosed Owned by: dd32
Milestone: Priority: normal
Component: WordPress.tv Keywords:
Cc:

Description

This only seems on the archive pages perhaps:

https://cldup.com/U0oyBiWD-W.png

Seen in Chrome on https://wordpress.tv/event/wordcamp-europe-2018/. Props to @melchoyce for discovering this.

Change History (9)

#1 @Otto42
12 months ago

Not happening in Windows 10 Chrome Version 70.0.3528.4 (Official Build) dev (64-bit).

#2 @tellyworth
12 months ago

Looks fine to me in Chrome 68.0.3440.106 and Safari 11.1.2, both on Macos 10.13.6.

#3 @netweb
12 months ago

Also not seeing this with Chrome Version 70.0.3528.4 (Official Build) dev (64-bit) on Mac

#4 @ryelle
12 months ago

It looks like this is only an issue for Automatticians. I can reproduce it when logged in to WP.com + proxied, but it's fine when not logged in, or not proxied. The iframe code itself is different (width & src domain), and incorrectly wider when logged in.

Not logged in, looks correct (Chrome/Mac):

<iframe width="575" height="323.1404958677686" src="https://videopress.com/embed/qjOKaoL2?hd=1&amp;autoPlay=0&amp;permalink=0&amp;loop=0" frameborder="0" allowfullscreen=""></iframe>

Logged in, broken (Chrome/Mac):

<iframe width="605" height="340" src="https://video.wordpress.com/embed/qjOKaoL2?hd=1&amp;autoPlay=0&amp;permalink=0&amp;loop=0" frameborder="0" allowfullscreen=""></iframe>

I'm not sure if this is a problem with the way the theme embeds videos, or if the issue is with videopress, though.

#5 @casiepa
12 months ago

  • Component changed from General to WordPress.tv

#6 @dd32
11 months ago

  • Owner set to dd32
  • Resolution set to fixed
  • Status changed from new to closed

In 7698:

WordPress.TV: Define the actual width of the non-single videos as 575px.

This fixes the VideoPress player width for Automatticians whose VideoPress player differs slightly from the public player.

Fixes #3779.

#7 @dd32
11 months ago

Just noting that although I've closed this, it won't be live on WordPress.TV until I sync the open-sourced theme changes to the production copy used by WordPress.TV.

#8 @dd32
11 months ago

I should also add that this could be taken as a bug in either the theme, or the a8c VideoPress player, or both.

I wasn't able to determine what would be needed in VideoPress to fix it, the public JS has some code to restrict it to the width of the parent element, where as the a8c player appears to skip that code for an unknown reason - Perhaps due to the different domain name as mentioned in comment 4..

This ticket was mentioned in Slack in #meta by casiepa. View the logs.


9 months ago

Note: See TracTickets for help on using tickets.