WordPress.org

Making WordPress.org

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#378 closed defect (fixed)

Dashicon for Make/Docs Headline Not Displaying

Reported by: kpdesign Owned by: Otto42
Milestone: Priority: normal
Component: Make (Get Involved) / P2 Keywords: has-patch
Cc:

Description

The dashicon for the Make/Docs blog headline is not displaying.

The body class is make-docs, but the stylesheet uses body.make-documentation for the headline.

Attachments (2)

378-make-docs-missing-dashicon.png (4.9 KB) - added by kpdesign 6 years ago.
378.diff (740 bytes) - added by kpdesign 6 years ago.

Download all attachments as: .zip

Change History (10)

@kpdesign
6 years ago

#1 @kpdesign
6 years ago

  • Keywords has-patch added

#2 @kpdesign
6 years ago

378.diff includes fix for missing dashicon.

#3 @Otto42
6 years ago

  • Owner set to Otto42
  • Resolution set to fixed
  • Status changed from new to closed

In 448:

Fix body class for make docs. props kpdesign. Fixes #378

#4 @nacin
6 years ago

FWIW that actually comes from the make home theme. Slug appears to be off there.

#5 @Otto42
6 years ago

No, the make home theme has its own stylesheet that doesn't affect this.

#6 @nacin
6 years ago

Sorry, I wasn't clear. Those lines of CSS were copied directly from https://meta.trac.wordpress.org/browser/sites/trunk/wordpress.org/public_html/wp-content/themes/pub/wporg-makehome/style.css?rev=127#L223. It seems make home uses "documentation" as a slug. That's why this bug occurred.

#7 @Otto42
6 years ago

Oh. Yeah, make-home picks the post_class based on the title of the entry in question. The generic wporg-p2 theme bases its body_class on the slug in the URL of the site. Since "docs" != "documentation", there you go.

Copy/paste error. Understandable.

#8 @nacin
6 years ago

In 449:

Make WP.org home: Use post_name for site classes. see #378.

Note: See TracTickets for help on using tickets.