WordPress.org

Making WordPress.org

Opened 16 months ago

Closed 15 months ago

Last modified 15 months ago

#3787 closed defect (fixed)

Broken edit links on Gutenberg handbook inner page

Reported by: DannyCooper Owned by:
Milestone: Priority: normal
Component: Handbooks Keywords: neso
Cc:

Description

On this page - https://wordpress.org/gutenberg/handbook/outreach/articles/

The edit link is:

https://github.com/WordPress/gutenberg/edit/master/outreach/docs/articles.md

but it should be:

https://github.com/WordPress/gutenberg/edit/master/docs/outreach/articles.md

This doesn't seem to be broken on any other inner pages.

(That page also doesn't seem to update with the Github page)

Change History (3)

#1 @tellyworth
15 months ago

  • Keywords neso added

#2 @dd32
15 months ago

  • Resolution set to fixed
  • Status changed from new to closed

I've been unable to find the source of the bug, however have fixed the main cause.

The Github Markdown Source was incorrectly set to https://raw.githubusercontent.com/WordPress/gutenberg/master/outreach/docs/articles.md
As this seems to have been the only page affected, I'm going to assume it was probably caused by a bad import of pages early in the handbooks life.

If this crops up anywhere else, to manually fix it:

  • Open the page in question in the Classic Editor
  • Fix the Markdown url, hit UPDATE (Not Import)
  • Upon Reload, hit Import to re-import the page from Markdown.

If successful, you should now be redirected to a Gutenberg page. If the source is still incorrect, you'll get an ugly error page.

Version 0, edited 15 months ago by dd32 (next)

#3 @dd32
15 months ago

Turns out that the markdown_source above comes from the Gutenberg docs manifest file, which has the typo in it.

Created a PR for Gutenberg to fix it: https://github.com/WordPress/gutenberg/pull/9781

Going to leave this as closed, as it wasn't a bug within the handbooks.

Note: See TracTickets for help on using tickets.