WordPress.org

Making WordPress.org

Opened 12 months ago

Closed 12 months ago

Last modified 12 months ago

#3812 closed defect (fixed)

Link errors on make.wordpress.org

Reported by: josh2k5 Owned by: dd32
Milestone: Priority: normal
Component: General Keywords:
Cc:

Description

There are two separate issues stemming from the same function via the "About WordPress" link on the top left header. One when logged into wordpress.org and one when not logged into wordpress.org.

Replication:
1) Login to wordpress.org
2) Navigate to make.wordpress.org
3) Hover over the WordPress icon in the top left corner
4) Click on 'About WordPress'
This will redirect you to https://make.wordpress.org/wp-admin/user/about.php, which will then display your profile. It should link to https://wordpress.org/about/ instead.

Replication 2:
1) Log out of wordpress.org
2) Navigate to make.wordpress.org
3) Hover over the WordPress icon in the top left corner
4) Click on 'About WordPress'
This will redirect you to https://make.wordpress.org/about/, which is a 404 and instead should link to https://wordpress.org/about/

Change History (6)

#1 @mukesh27
12 months ago

  • Resolution set to worksforme
  • Status changed from new to closed

Hi @josh2k5, welcome to WordPress Meta Trac!

Links are working fine in both steps.

#2 @nikolam
12 months ago

  • Resolution worksforme deleted
  • Status changed from closed to reopened

I can confirm that the issue is real, at least for me as well.

@mukesh27 did you try it out at https://make.wordpress.org/?

While logged in:

<a class='ab-item' aria-haspopup="true" href='https://make.wordpress.org/wp-admin/user/about.php'><span class="ab-icon"></span><span class="screen-reader-text">About WordPress</span></a>

When logged out:

<a class='ab-item' aria-haspopup="true" href='/about/'><span class="ab-icon"></span><span class="screen-reader-text">About WordPress</span></a>

So the problem when user is logged out is in relative URL, but no clue about first problem.

#3 @Otto42
12 months ago

  • Keywords good-first-bug added

Yes, I see the issue. However that should not link to https://wordpress.org/about in either case, because that is the link for the normal /wp-admin WordPress about page in core, not a specific one to WordPress.org. You will see the same link on your own WordPress sites, linking to your About page.

When logged out, you normally would not see the Admin Bar at all. We have a plugin to make it visible in relevant places. Seems like that plugin could use some additional filters for that menu.

That code is here. It seems to be modifying the about link somewhat incorrectly. Ideas as to where it should go, and what should be in the menu as a whole (as well as patches) are welcome.

https://meta.trac.wordpress.org/browser/sites/trunk/wordpress.org/public_html/wp-content/mu-plugins/pub/wporg-admin-bar.php

#4 @dd32
12 months ago

  • Owner set to dd32
  • Resolution set to fixed
  • Status changed from reopened to closed

In 7674:

Toolbar: Link the (w) and (w)->About links to the localised WordPress.org About pages.

Previously the logged out versions of these were redirected to /about/ which didn't make sense on the make blog or other non-rosetta subdomains.

Fixes #3812.

#5 @Otto42
12 months ago

  • Keywords good-first-bug removed

Alright, I admit, I didn't think about the rosetta sites. That fix makes the most sense. :)

#6 @dd32
12 months ago

I think it was deliberately using a relative link due to rosetta sites, pushing a domain into it seemed like the most obvious solution so that it'd still work for them and the make blog (plus who knows what other non-rosetta subdomains)

I've also changed it for logged in users, because having a different link for logged out vs logged in seemed a bit strange - plus if you -need- to see wp-admin/about.php on W.org, I'm sure you know to type it in directly.

Note: See TracTickets for help on using tickets.