WordPress.org

Making WordPress.org

Opened 14 months ago

Closed 14 months ago

Last modified 14 months ago

#3823 closed defect (fixed)

Using Locale Switcher on Logout Page redirects to Profile page

Reported by: garrett-eclipse Owned by: dd32
Milestone: Priority: normal
Component: Login & Authentication Keywords:
Cc:

Description

Hello,

While writing #3821 I noticed that using the Locale Switcher on the Logout page redirects you to your profile page.

To reproduce;

  1. Make sure you're logged in.
  2. From this Trac ticket click Logout at the top of the page.
  3. From the https://login.wordpress.org/logout page use the Locale Switcher to select an alternate language
  4. Note that you've been redirected to your profile.

Now if the result of #3821 is to remove the logout and loggedout pages from the flow and instead logout and reload current page then users won't be able to get to the logout page so this issue is moot.... But if the logout page will continue to exist moving forward then this would be an issue.

I believe what happens is when the Locale Switcher is invoked the user is taken from the logout page to the login page with the locale appended. And since the login page has logic detecting if a user is logged in and redirecting to their profile then this occurs.

Thanks

Attachments (1)

Screen Shot 2018-09-21 at 10.00.37 AM.png (129.3 KB) - added by garrett-eclipse 14 months ago.
Logout Page w/ Locale Switcher

Download all attachments as: .zip

Change History (3)

@garrett-eclipse
14 months ago

Logout Page w/ Locale Switcher

#1 @dd32
14 months ago

  • Owner set to dd32
  • Resolution set to fixed
  • Status changed from new to closed

In 7695:

Login: Allow query parameters on the /logout route. This is needed to support the locale switcher, and future custom redirection locations.

See #3821.
Fixes #3823.

#2 @garrett-eclipse
14 months ago

Thanks @dd32 tested and functioning

Note: See TracTickets for help on using tickets.