WordPress.org

Making WordPress.org

Opened 6 years ago

Closed 4 years ago

#388 closed defect (fixed)

Plugins: "How to Use Subversion" needs to be updated for https

Reported by: Ipstenu Owned by:
Milestone: Priority: normal
Component: Plugin Directory Keywords:
Cc:

Description

https://wordpress.org/plugins/about/svn/

(If there was a place I could do a pull request from or grab to submit a patch from, let me know)

Change History (6)

#1 @Otto42
6 years ago

Subversion still works on http, it does not require https at present.

#2 @Otto42
6 years ago

#389 was marked as a duplicate.

#3 @Ipstenu
6 years ago

Check with https://twitter.com/developdaly/status/441375619947835393

Other people have said the same problem's happening.

#4 @Otto42
6 years ago

Umm.. No, I'm able to commit using http (not https) just fine.

Now, some users may be in odd situations or behind proxies or something, and using https allows their traffic to go through those, perhaps, but as far as I know, we do not require SSL connections on the various SVNs at this point in time.

#5 @dd32
6 years ago

If we support HTTPS though, we might as well suggest people use it from the start though..

Although I do believe Mac + CLI HTTPS SVN can lead to certificate warnings.

#6 @samuelsidler
4 years ago

  • Resolution set to fixed
  • Status changed from new to closed

I dunno when, but this got updated with https at some point. Anyway, we should redirect the pages to the plugin developer handbook. See #1056.

Note: See TracTickets for help on using tickets.